Bug 56199 - if{up,down} broken with 7.2 and non-redhat kernel
if{up,down} broken with 7.2 and non-redhat kernel
Status: CLOSED DUPLICATE of bug 55846
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-11-13 15:46 EST by Mike Snitzer
Modified: 2014-03-16 22:24 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-11-13 15:46:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Mike Snitzer 2001-11-13 15:46:08 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.2.18-plogic-10b.bproc i686;

Description of problem:
If I boot the redhat 2.4.7 kernel that shipped with 7.2 the if{up,down}
scripts run fine.. and I get no errors while booting or when I run /sbin/ip
-o link BUT:

upon booting redhat 7.2 with the very same custom 2.4.x kernels that worked
perfectly fine with initscripts-5.84 under redhat 7.1; I see that all my
network interfaces fail when they attempt to be bought up with the error:
"Cannot send dump request: Connection refused" .  

manually attempting to bring up the loopback interface with: ifup lo fails
with the same error message, but its return code is 0... strange.

Also, when I then try: /sbin/ip -o link  I get that same "..: Connection
refused" error.  

Using the ifup from initscripts-5.84, instead of initscripts-6.40, with my
custom linux kernel; I was able to bring up all my interfaces without any
problems.  However, ifdown from both initscript versions does _not_ work
under Redhat 7.2 with my kernel; I can send my .config if you really
question the basic networking ability of my custom 2.4.14 kernel; my
orinoco wireless card works just fine... below you'll see the network
protocols my kernel supports.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. boot non-RedHat linux kernel >=2.4.13
2. ifup lo
3. /sbin/ip -o link

Actual Results:  1. you see network interfaces [FAILED] during bootup
2 & 3. "Cannot send dump request: Connection refused"

Expected Results:  the interfaces should've been brought up

Additional info:

these are my network entries from /proc/net as seen with my custom 2.4.14
arp            netstat        rt_cache       softnet_stat   wireless
dev            packet         rt_cache_stat  tcp            
dev_mcast      raw            snmp           udp            
netlink        route          sockstat       unix
Comment 1 Bill Nottingham 2001-11-13 15:52:37 EST

*** This bug has been marked as a duplicate of 55846 ***

Note You need to log in before you can comment on or make changes to this bug.