Bug 55846 - the network script fails to load network using a custom kernel
Summary: the network script fails to load network using a custom kernel
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts   
(Show other bugs)
Version: 7.2
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
: 56199 56293 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-11-07 18:00 UTC by Need Real Name
Modified: 2014-03-17 02:24 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-07 18:00:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2001-11-07 18:00:23 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.10 i586)

Description of problem:
Upgrade from 7.1 to 7.2 which an existing working 2.4.13 kernel. When
booting after the upgrade eth0 fails to get assigned an IP address, default
route is not set etc. have traced this down to the ifup script is using a
different command, ip instead of ifconfig, to setup the device. After the
system boots the device can be setup correctly using ifconfig with
appropriate options.

The root problem seems to be that a kernel compiled without the netlink
socket option under networking options causes the ip command  to fail.
Recompiling with the netlink socket enabled the ip command works and
network is setup at boot time. ifconfig works regardless of the netlink
option, 7.1 script was using ifconfig to setup the device.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. configure kernel without netlink socket
2. boot new kernel
3. watch error messages regarding lo, eth0
	

Actual Results:  same as above

Expected Results:  networking should setup correctly on system boot.

Additional info:

script should have some fall back to use ifconfig if ip command fails.

Comment 1 Bill Nottingham 2001-11-07 19:04:47 UTC
netlinks socket is required. See the release notes for details.

Comment 2 Bill Nottingham 2001-11-13 20:52:30 UTC
*** Bug 56199 has been marked as a duplicate of this bug. ***

Comment 3 Bill Nottingham 2001-11-15 19:16:15 UTC
*** Bug 56293 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.