Bug 562097 - Rename request: libsocialweb - A social network data aggregator
Rename request: libsocialweb - A social network data aggregator
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Michel Alexandre Salim
Fedora Extras Quality Assurance
:
Depends On:
Blocks: MeeGo1
  Show dependency treegraph
 
Reported: 2010-02-05 03:36 EST by Peter Robinson
Modified: 2010-05-23 17:34 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-23 17:34:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
michel: fedora‑review+
kevin: fedora‑cvs+


Attachments (Terms of Use)

  None (edit)
Description Peter Robinson 2010-02-05 03:36:32 EST
SPEC: http://pbrobinson.fedorapeople.org/libsocialweb.spec
SRPM: http://pbrobinson.fedorapeople.org/libsocialweb-0.23.1-1.fc12.src.rpm

Description:
libsocialweb is a social data server which fetches data from the "social web",
such as your friend's blog posts and photos, upcoming events, recently played
tracks, and pending eBay* auctions. It also provides a service to update
your status on web services which support it, such as MySpace* and Twitter*.

Original package review was https://bugzilla.redhat.com/show_bug.cgi?id=506486

Note Obsoletes/Provides not added as yet as some packages still depend on mojito. The transition will be complete by late March early April in time for the final Moblin 2.2
Comment 2 Michel Alexandre Salim 2010-03-31 14:44:48 EDT
I did a diff to the current mojito.spec from the development branch, and the diff looks reasonable -- though there are some oddities:

(for main package)

+%{_libdir}/libsocialweb*.0 .2
+%{_libdir}/libsocialweb*.1

won't libsocialweb*.so.* be clearer -- and won't break when they bump the soname?

(for devel)

+%{_libdir}/libsocialweb*so

likewise here -- libsocialweb*.so is probably more canonical
Comment 3 Peter Robinson 2010-03-31 14:49:55 EDT
Agreed. Will update.
Comment 4 Michel Alexandre Salim 2010-03-31 15:39:47 EDT
Here's the full review. The license need to be reverted to what mojito has (but with LGPLv2, not LGPLv2.1 --
  see http://fedoraproject.org/wiki/Licensing#Good_Licenses

And if you could locate a source tarball now that moblin.org is down, and update the SRPM, I could approve the review.

Review
======

Problems
--------
rpmlint: only one real warning, the invalid URL. Change to new MeeGo URL when committing

$ rpmlint libsocialweb-0.24.0-1.fc12.src.rpm ~/Downloads/libsocialweb*
libsocialweb.src: W: spelling-error Summary(en_US) aggregator -> aggregation, aggregate, aggressor
libsocialweb.src: W: invalid-url Source0: http://download.moblin.org/sources/libsocialweb/0.24/libsocialweb-0.24.0.tar.bz2 HTTP Error 404: Not Found
libsocialweb.x86_64: W: spelling-error Summary(en_US) aggregator -> aggregation, aggregate, aggressor
4 packages and 0 specfiles checked; 0 errors, 3 warnings.

License accurate:     FIX -- a spot check shows that many files are LGPLv2
  without any mention of using any later version.

Upstream source:      FIX -- can't check until MeeGo downloads available


Passes
------
Package & spec names: OK
Fit for inclusion:    OK (rename of existing mojito)
Content:              OK
License acceptable:   OK
License included:     OK
Spec language:        OK (US English, legible)

Compiles:             OK
  see http://koji.fedoraproject.org/koji/taskinfo?taskID=2087590
Complete BRs:         OK

Locale:               OK

ldconfig:             OK
no bundled libs:      OK

Dir ownership:        OK
No dup files:         OK
File perms:           OK
UTF-8 files:          OK

%clean:               OK
rm on %install:       OK
Consistent macros:    OK

Large docs:               NA
%doc unessential:         OK
Headers in -devel:        OK
*.so.* -> *.so in -devel: OK
Static in -static:        NA
-devel Req: main:         OK
No .la:                   OK

Desktop files:            NA
Comment 5 Christoph Wickert 2010-04-06 15:32:52 EDT
If this is a renamed mojito, it needs Provides:/Obsoltes: for it. See 
http://fedoraproject.org/wiki/Packaging/NamingGuidelines#Renaming.2Freplacing_existing_packages
Comment 6 Peter Robinson 2010-04-06 15:55:54 EDT
(In reply to comment #5)
> If this is a renamed mojito, it needs Provides:/Obsoltes: for it. See 
> http://fedoraproject.org/wiki/Packaging/NamingGuidelines#Renaming.2Freplacing_existing_packages    

That is known. See note in comment 1
Comment 7 Peter Robinson 2010-05-12 04:38:10 EDT
OK. We're on again. We have a git repo of the code! So updated....

SPEC: http://pbrobinson.fedorapeople.org/libsocialweb.spec
SRPM: http://pbrobinson.fedorapeople.org/libsocialweb-0.24.8-1.fc13.src.rpm
koji: http://koji.fedoraproject.org/koji/taskinfo?taskID=2182111
Comment 8 Michel Alexandre Salim 2010-05-19 15:22:55 EDT
Everything looks fine. APPROVED.

As a side note, if libsocialweb is not source-compatible with mojito (as in mojito-dependent packages could be rebuilt to depend on it), then I don't see why a Provides/Obsoletes needs to be added at all.
Comment 9 Peter Robinson 2010-05-20 10:16:51 EDT
(In reply to comment #8)
> Everything looks fine. APPROVED.

Thanks

> As a side note, if libsocialweb is not source-compatible with mojito (as in
> mojito-dependent packages could be rebuilt to depend on it), then I don't see
> why a Provides/Obsoletes needs to be added at all.    

It will primarily be enable clean upgrades due to packages that currently depend on mojito will depend on l-s-w so we don't leave mojito around.
Comment 10 Peter Robinson 2010-05-20 10:20:40 EDT
New Package CVS Request
=======================
Package Name: libsocialweb
Short Description: A social network data aggregator
Owners: pbrobinson
Branches: F-13
InitialCC:
Comment 11 Kevin Fenzi 2010-05-20 15:36:42 EDT
CVS done (by process-cvs-requests.py).
Comment 12 Peter Robinson 2010-05-23 17:34:00 EDT
Built and in rawhide. Thanks

Note You need to log in before you can comment on or make changes to this bug.