Bug 562447 - dbus permission prevents lcd brigthess control
dbus permission prevents lcd brigthess control
Status: CLOSED DUPLICATE of bug 499183
Product: Fedora
Classification: Fedora
Component: kdebase-workspace (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-06 14:39 EST by Armands Liepins
Modified: 2010-02-06 16:11 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-06 16:11:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Armands Liepins 2010-02-06 14:39:32 EST
Description of problem:
Screen Brightness control in the Power Management applet does not work. 
The slider stays at leftmost position although brightness is at maximum, moving it does nothing. The problem started after some package update. If restart messagebus, brightness control starts to work until the next login.

in the /var/log/messages:

Feb  6 19:30:01 localhost dbus: Rejected send message, 1 matched rules; type="method_call", sender=":1.18" (uid=500 pid=4072 comm="/ur/bin/plasma-desktop) interface="org.freedesktop.Hal.Device.LaptopPanel" member="SetBrightness" error name="(unset)" requested_reply= destination="org.freedesktop.Hal" (uid=68 pid=1164 comm="hald))
Feb  6 19:30:01 localhost dbus: Rejected send message, 1 matched rules; type="method_call", sender=":1.18" (uid=500 pid=4072 comm="/ur/bin/plasma-desktop) interface="org.freedesktop.Hal.Device.LaptopPanel" member="GetBrightness" error name="(unset)" requested_reply= destination="org.freedesktop.Hal" (uid=68 pid=1164 comm="hald))

these seems to be related:

Feb  6 19:27:55 localhost dbus: Rejected send message, 1 matched rules; type="method_call", sender=":1.17" (uid=500 pid=4058 comm="kded4) interface="org.freedesktop.Hal.Device.CPUFreq" member="GetCPUFreqAvailableGovernors" error name="(unset)" requested_reply=0 destination="org.freedesktop.Hal" (uid=68 pid=1164 comm="hald))
...
Feb  6 20:06:34 localhost dbus: Rejected send message, 1 matched rules; type="method_call", sender=":1.17" (uid=500 pid=4058 comm="kded4) interface="org.freedesktop.Hal.Device.SystemPowerManagement" member="SetPowerSave" error name="(unset)" requested_reply=0 destination="org.freedesktop.Hal" (uid=68 pid=1164 comm="hald))

Version-Release number of selected component (if applicable):
kdebase-workspace-4.3.5-2.fc12.i686

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
some other related package versions:
hal-0.5.13-9.fc12.i686
ConsoleKit-0.4.1-3.fc12.i686
ConsoleKit-libs-0.4.1-3.fc12.i686
dbus-1.2.16-9.fc12.i686
ConsoleKit-x11-0.4.1-3.fc12.i686
DeviceKit-power-014-1.fc12.i686
kdm-4.3.5-2.fc12.i686
This happnens on ASUS X80L laptop.
Comment 1 Kevin Kofler 2010-02-06 14:56:04 EST
I think this is one of the "something creates /tmp/.X11-unix with a wrong SELinux context, preventing pam_console and thus D-Bus's at_console detection from working" bugs, i.e. bug 499183 or bug 550013.
Comment 2 Armands Liepins 2010-02-06 15:48:35 EST
Yes, that was it, doing restorecon /tmp/.X11-unix fixed the problem. This fixed bug 562452 too. Now question is why it is creating with wrong context?
Comment 3 Kevin Kofler 2010-02-06 15:55:20 EST
Well, do you have freenx-server installed? Or maybe tigervnc-server (the vncserver executable)?
Comment 4 Armands Liepins 2010-02-06 16:04:29 EST
(In reply to comment #3)
Yes, I have freenx-server installed, wanted to write comment about this, but you was first.
Comment 5 Kevin Kofler 2010-02-06 16:11:52 EST

*** This bug has been marked as a duplicate of bug 499183 ***

Note You need to log in before you can comment on or make changes to this bug.