Bug 562605 - resize2fs problems making rawhide live images.
resize2fs problems making rawhide live images.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: e2fsprogs (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Eric Sandeen
Fedora Extras Quality Assurance
:
Depends On:
Blocks: SOAS-3
  Show dependency treegraph
 
Reported: 2010-02-07 11:54 EST by Kevin Fenzi
Modified: 2010-03-09 16:36 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-09 16:36:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Fenzi 2010-02-07 11:54:13 EST
We are seeing problems making the soas (both i686 and x86_64) and design-suite (only i686) nightly live composes from rawhide. 

soas/i686: 

e2image 1.41.9 (22-Aug-2009)
resize2fs 1.41.9 (22-Aug-2009)
Resizing the filesystem on /var/tmp/imgcreate-qS5efL/tmp-2tEJqL/ext3fs.img to 786432 (4k) blocks.
The filesystem on /var/tmp/imgcreate-qS5efL/tmp-2tEJqL/ext3fs.img is now 786432 blocks long.

e2fsck 1.41.9 (22-Aug-2009)
Pass 1: Checking inodes, blocks, and sizes
Pass 2: Checking directory structure
Pass 3: Checking directory connectivity
Pass 4: Checking reference counts
Pass 5: Checking group summary information
Free blocks count wrong for group #16 (32254, counted=28656).
Fix? yes

Free blocks count wrong (364585, counted=360987).
Fix? yes


soas-i386-201002: ***** FILE SYSTEM WAS MODIFIED *****
soas-i386-201002: 80224/196608 files (0.1% non-contiguous), 425445/786432 blocks
/usr/lib/python2.6/site-packages/imgcreate/errors.py:45: DeprecationWarning: BaseException.message has been deprecated as of Python 2.6
  return unicode(self.message)
Error creating Live CD : fsck after resize returned an error!  image to debug at /tmp/resize-image-_cFk2j

soas x86_64: 

e2image 1.41.9 (22-Aug-2009)
resize2fs 1.41.9 (22-Aug-2009)
Resizing the filesystem on /var/tmp/imgcreate-QebiEU/tmp-nSRGlN/ext3fs.img to 786432 (4k) blocks.
The filesystem on /var/tmp/imgcreate-QebiEU/tmp-nSRGlN/ext3fs.img is now 786432 blocks long.

e2fsck 1.41.9 (22-Aug-2009)
Pass 1: Checking inodes, blocks, and sizes
Pass 2: Checking directory structure
Pass 3: Checking directory connectivity
Pass 4: Checking reference counts
Pass 5: Checking group summary information
Free blocks count wrong for group #16 (32254, counted=28656).
Fix? yes

Free blocks count wrong (352037, counted=348439).
Fix? yes


soas-x86_64-2010: ***** FILE SYSTEM WAS MODIFIED *****
soas-x86_64-2010: 80143/196608 files (0.1% non-contiguous), 437993/786432 blocks
/usr/lib/python2.6/site-packages/imgcreate/errors.py:45: DeprecationWarning: BaseException.message has been deprecated as of Python 2.6
  return unicode(self.message)
Error creating Live CD : fsck after resize returned an error!  image to debug at /tmp/resize-image-CNcZ2O

design-suite: 

e2image 1.41.9 (22-Aug-2009)
resize2fs 1.41.9 (22-Aug-2009)
Resizing the filesystem on /var/tmp/imgcreate-RW2p0s/tmp-XplhG1/ext3fs.img to 683767 (4k) blocks.
The filesystem on /var/tmp/imgcreate-RW2p0s/tmp-XplhG1/ext3fs.img is now 683767 blocks long.

e2fsck 1.41.9 (22-Aug-2009)
Pass 1: Checking inodes, blocks, and sizes
Pass 2: Checking directory structure
Pass 3: Checking directory connectivity
Pass 4: Checking reference counts
Pass 5: Checking group summary information
Free inodes count wrong for group #16 (8192, counted=8190).
Fix? yes

Free inodes count wrong (70404, counted=70402).
Fix? yes


design-suite-i38: ***** FILE SYSTEM WAS MODIFIED *****
design-suite-i38: 101630/172032 files (0.1% non-contiguous), 676366/683767 blocks
/usr/lib/python2.6/site-packages/imgcreate/errors.py:45: DeprecationWarning: BaseException.message has been deprecated as of Python 2.6
  return unicode(self.message)
Error creating Live CD : fsck after resize returned an error!  image to debug at /tmp/resize-image-Ood7k1

I have the image files here: http://www.scrye.com/~kevin/fedora/e2resizefs-bug-20100207/

Let me know if I can provide anymore info or assistance.
Comment 1 Eric Sandeen 2010-02-07 13:49:47 EST
Heh, what would a Fedora release be, without a resize2fs bug getting uncovered by anaconda? :)

I'll look at the images; if I can reproduce the bug w/ those that's all the info I need, thanks!

-Eric
Comment 2 Eric Sandeen 2010-02-07 14:12:53 EST
Kevin, which e2fsprogs rpm is this, e2fsprogs-1.41.9-9.fc13?

so far it seems ok to me:

[root@inode bz562605]# rpm -q e2fsprogs
e2fsprogs-1.41.9-9.fc13.x86_64

[root@inode bz562605]# resize2fs resize-image-_cFk2j 786432
resize2fs 1.41.9 (22-Aug-2009)
Resizing the filesystem on resize-image-_cFk2j to 786432 (4k) blocks.
The filesystem on resize-image-_cFk2j is now 786432 blocks long.

[root@inode bz562605]# e2fsck -fy resize-image-_cFk2j
e2fsck 1.41.9 (22-Aug-2009)
Pass 1: Checking inodes, blocks, and sizes
Pass 2: Checking directory structure
Pass 3: Checking directory connectivity
Pass 4: Checking reference counts
Pass 5: Checking group summary information
soas-i386-201002: 80224/196608 files (0.1% non-contiguous), 425445/786432 blocks

I did have a bad patch in there, though; if it is possible for you to manually test with 1.41.9-8 I'd appreciate it, I think that may resolve the issue.  Or, try rebuilding e2fsprogs with Patch10 removed...

I'll try the other images to see if I can hit it on those.

Thanks,
-Eric
Comment 3 Kevin Fenzi 2010-02-07 14:19:39 EST
Yeah, on the host is: 
e2fsprogs-1.41.9-9.fc13.x86_64

I can try with -8.
Comment 4 Eric Sandeen 2010-02-07 14:27:45 EST
Thanks; I couldn't reproduce w/ any of the images, unfortunately.  I'll take a look and see if they're being created properly...
Comment 5 Chris 2010-02-22 19:01:42 EST
FWIW, saw the same thing on F12 after upgrading to e2fsprogs-1.41.9-6; downgrading to -5 remedied.
Comment 6 Kevin Fenzi 2010-02-22 19:38:16 EST
The versions after -10 all fix it here. ;)
Comment 7 Eric Sandeen 2010-02-22 20:19:54 EST
Chris, the F12 issue is known & fixed; -7 should also fix it.  It's in stable now.
See bug #566905

Kevin, 1.41.9-9 in rawhide had that same bug, but I don't know of any before or after that ... so you must have hit something else - but it's fixed now?

If so (magically fixed) maybe we should close this ...

-Eric
Comment 8 Kevin Fenzi 2010-02-22 22:36:26 EST
Has not happened here in a while... I'd be fine to close this. ;)
Comment 9 Eric Sandeen 2010-03-09 16:36:57 EST
Kevin says it's fixed now :)

Note You need to log in before you can comment on or make changes to this bug.