This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 56266 - execution of %post scriptlet fails
execution of %post scriptlet fails
Status: CLOSED NOTABUG
Product: Red Hat Raw Hide
Classification: Retired
Component: fileutils (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Aaron Brown
:
: 59798 59997 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-14 14:22 EST by CoreDump
Modified: 2007-04-18 12:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-14 14:22:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description CoreDump 2001-11-14 14:22:09 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.7-0.8 i586)

Description of problem:
install-info: menu item `yes' already exists, for file `sh-utils'
error: execution of %post scriptlet from fileutils-4.1.1-1 failed, exit
status 1


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. rpm -U fileutils-4.1.1.-1.rpm

I have sh-utils and fileutils from the previous distribution already
installed


Additional info:
Comment 1 Bernhard Rosenkraenzer 2001-11-17 09:04:34 EST
You need to upgrade sh-utils at the same time (they're using the same info 
page these days).
Comment 2 CoreDump 2001-11-18 17:11:52 EST
I did so, the bug message still exists.

After install:
# rpm -q sh-utils
sh-utils-2.0.11-7

# rpm -q fileutils
fileutils-4.1-3
fileutils-4.1.1-1

As you can see, the older version is also reported by rpm.
Comment 3 CoreDump 2001-11-18 18:04:02 EST
Ok, the problem is that /etc/info-dir already has entries like:
* yes: (sh-utils)yes invocation.               Print a string indefinitely.

This rpm (fileutils-4.1.1-1) wants to change it like:
* yes: (coreutils)yes invocation.               Print a string indefinitely.

Instead of changing the entry, it complains and fails to completely upgrade.
I consider this a bug which requires a lot of manual editing in /etc/info-dir
to remedy. Cutting all of the lines with (sh-utils), (textutils), (fileutils)
and 3-4 other lines made upgrading possible.
Comment 4 Sammy 2001-11-25 10:15:41 EST
The latest sh-utils and fileutils-4.1.2-1 still has the bug!! 
Comment 5 Bernhard Rosenkraenzer 2002-02-14 13:31:40 EST
*** Bug 59798 has been marked as a duplicate of this bug. ***
Comment 6 Bernhard Rosenkraenzer 2002-02-18 15:14:00 EST
*** Bug 59997 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.