Bug 56279 - xinetd.d conf files cause IDENT timeout
Summary: xinetd.d conf files cause IDENT timeout
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: imap (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 58283 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-11-14 21:54 UTC by Mike McHenry
Modified: 2007-04-18 16:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-20 04:32:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mike McHenry 2001-11-14 21:54:15 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
The xinetd.d config files for the imap package all include a line 
log_on_success and log_on_failure = USERID.

This line causes a 30 second timeout whenever a client which is not 
running an IDENTD daemon (any Windows machine) attempts to connect to a 
daemon (ipop2, ipop3, imap, imaps, pop3s)

In my opinion a 30 second delay should not be introduced when 90% of the 
people checking email will be running Windows clients and will thus not 
have an IDENTD daemon running.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Simply attempt to connect to port 110, 143, etc from a client which is 
not running an IDENTD daemon (eg Windows 9x)


Actual Results:  Server will hang for 30 seconds while IDENTD lookup times 
out...

Expected Results:  Server should immediately answer on these ports...

Additional info:

Comment 1 Mike A. Harris 2001-11-20 04:32:50 UTC
If this problem is in fact the case, then I agree with you.  Will
investigate, and change default if I can reproduce the problem
easily, which I suspect shouldn't be hard.  Very odd nobody has
reported this before.  ;o(

Comment 2 Mike A. Harris 2001-11-20 10:13:31 UTC
I have changed all of the xinetd config files to log as follows, and
removed all references to USERID:

        log_on_success  += HOST DURATION
        log_on_failure  += HOST
Will be in rawhide imap-2001a packages soon.


Comment 3 Mike A. Harris 2002-01-23 13:47:47 UTC
*** Bug 58283 has been marked as a duplicate of this bug. ***

Comment 4 Ian Mortimer 2002-03-05 05:15:51 UTC
You don't need to add HOST to log_on_success or log_on_failure since that is
the default for xinetd anyway: set in /etc/xinetd.conf



Note You need to log in before you can comment on or make changes to this bug.