Bug 562854 - dhclient crashes when dhclient-script exits from BOUND section with nonzero status
dhclient crashes when dhclient-script exits from BOUND section with nonzero s...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dhcp (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Jiri Popelka
Fedora Extras Quality Assurance
:
: 565986 (view as bug list)
Depends On:
Blocks: 563458
  Show dependency treegraph
 
Reported: 2010-02-08 10:29 EST by Jiri Popelka
Modified: 2010-02-17 06:55 EST (History)
1 user (show)

See Also:
Fixed In Version: 4.1.1-5.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 563458 (view as bug list)
Environment:
Last Closed: 2010-02-11 09:45:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiri Popelka 2010-02-08 10:29:58 EST
Description of problem:
BOUND section in 'man 8 dhclient-script' says:
Before actually configuring the address, dhclient-script should somehow ARP for it and exit with a nonzero status if it receives a reply.
In this case, the client will send a DHCPDECLINE message to the server and acquire a different address.

But when I try to add to from BOUND section exit with nonzero status,
dhclient crashes

How reproducible:
Always

Steps to Reproduce:
1. Add 'exit_with_hooks 2' into dhclient-script's BOUND section
2. Run dhclient
  
Actual results:
dhclient sends DHCPDECLINE, but dies immediately afterwards

Expected results:
Unicorns shooting rainbows from their horn surrounded by singing pony's
Comment 1 Fedora Update System 2010-02-09 00:10:15 EST
dhcp-4.1.1-5.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update dhcp'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-0928
Comment 2 Fedora Update System 2010-02-11 09:45:04 EST
dhcp-4.1.1-5.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 3 Jiri Popelka 2010-02-17 06:55:01 EST
*** Bug 565986 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.