Bug 565986 - dhclient crash after suspend and resume in xen
dhclient crash after suspend and resume in xen
Status: CLOSED DUPLICATE of bug 562854
Product: Fedora
Classification: Fedora
Component: dhcp (Show other bugs)
12
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jiri Popelka
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-16 15:58 EST by Mikulas Patocka
Modified: 2010-03-02 11:05 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-17 06:55:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of the segfault (23.17 KB, image/png)
2010-02-16 15:58 EST, Mikulas Patocka
no flags Details

  None (edit)
Description Mikulas Patocka 2010-02-16 15:58:01 EST
Created attachment 394638 [details]
screenshot of the segfault

Hi

When testing other problems with out-of-memory condition (unrelated to this bug), I installed Fedora 12 in xen paravirtualization on x86-64, with 512 MB RAM and without swap. During install, Anaconda was killed Anaconda out-of-memory condition.

I suspended the XEN machine and resumed it a few days later and I saw a message about dhclient getting new address and crashing.

There was no way to debug it (the machine is dead). Hopefully, someone can determine what went wrong from the "EIP" address. The particular crashed binary is the one from Fedora 12 installer.
Comment 1 Jiri Popelka 2010-02-17 06:55:01 EST
The fact that dhclient segfaults after it sends DHCPDECLINE indicates that it's duplicate of Bug #562854.
I'm closing this as duplicate.
If you can reproduce this problem even with dhcp-4.1.1-5.fc12, feel free to reopen it.

*** This bug has been marked as a duplicate of bug 562854 ***

Note You need to log in before you can comment on or make changes to this bug.