Bug 56293 - network restart gives error message and networking does not work
network restart gives error message and networking does not work
Status: CLOSED DUPLICATE of bug 55846
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-15 00:27 EST by Joe Acosta
Modified: 2014-03-16 22:24 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-15 14:05:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joe Acosta 2001-11-15 00:27:21 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.5) Gecko/20011012

Description of problem:
I was using redhat 7.1, my networking worked. I upgraded to 7.2 and now it
does not. I am using the tulip ethernet driver and it worked before.  It is
NOT a kernel issue.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.cd to /etc/init.d 
2. type ./network restart                 
Shutting down interface eth0:                              [  OK  ]
Shutting down interface ppp0:                              [  OK  ]
Disabling IPv4 packet forwarding:                          [  OK  ]
Setting network parameters:                                [  OK  ]
Bringing up interface lo:                                  [  OK  ]
Cannot open netlink socket: Address family not supported by protocol
Bringing up interface eth0:                                
	

Additional info:

added set -x in script and it seems that in the is_availble this is coming
up I think ..

+ ip -o link
+ grep -q eth0
Cannot open netlink socket: Address family not supported by protocol
+ '[' 1 = 1 '
Comment 1 Joe Acosta 2001-11-15 12:35:17 EST
it is definately the ip -o link that is causing problems.  
The worst part is that it says OK to initializing the eth0 device but you cannot
ping the ip address that is supposed to be assigned to the device.
Comment 2 Bill Nottingham 2001-11-15 12:53:13 EST
Did you recompile the kernel at all?
Comment 3 Joe Acosta 2001-11-15 14:05:44 EST
Why do I need to recompile my kernel?  I am using 2.4.14, and I was using 2.4.14
with RH 7.1.  Why should that make a difference?  What changed that broke this?
Comment 4 Bill Nottingham 2001-11-15 14:16:21 EST
You need CONFIG_NETLINK and CONFIG_RTNETLINK enabled in your kernel.
See the release notes.

*** This bug has been marked as a duplicate of 55846 ***
Comment 5 Joe Acosta 2001-11-15 23:38:44 EST
This seems to have worked.

Note You need to log in before you can comment on or make changes to this bug.