Bug 56295 - (SOUND VIA82CXX_AUDIO)seemingly random kernel crashes/panics
(SOUND VIA82CXX_AUDIO)seemingly random kernel crashes/panics
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-15 01:40 EST by Frank Worsley
Modified: 2008-08-01 12:22 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 11:39:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frank Worsley 2001-11-15 01:40:45 EST
Description of Problem:
Since I installed 7.2 my system hangs seemingly at random every once in a
while. This can happen either 5 minutes after I rebooted and logged in or
after the system has been up for 24+ hours. I am not entirely sure if this
is a kernel issue, but there is a new /var/log/ksyms.X file whenever it
happens. I have to be actively using the system for it to happen and it
always happens while I am using XFree86 (I run Ximian Gnome). When it
happens I can be going anything in X, ie: web browing, reading email, word
processing, etc.
My machine is an Athlon TBird 750 (not overclocked), 385 megs of PC133 RAM
on an ASUS A7V mobo. Graphics card is an Rage Fury Pro (32 megs) running in
AGP1x mode.
I tried downloading the latest kernel from ftp.redhat.com (2.4.9-13-athlon)
but this still happens. I also commented out the "Load v4l" line in
XF86Config-4 because I thought it might be a conflict with DRI, that also
did not solve the problem.
If you would like me to attach any logs or the ksyms.X files please let me
know. The crashes have happened 20+ times in the last two weeks, it is very
annoying! :(


Version-Release number of selected component (if applicable):


How Reproducible:
Use X for a while and it will happen.


Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:
Comment 1 Arjan van de Ven 2001-11-15 05:42:54 EST
Can you try adding "noathlon" to the kernel commandline ?
(either do this in grub itself or, better, in /boot/grub/grub.conf ; add it to
the line with "vmlinuz" in it)
Comment 2 Frank Worsley 2001-11-15 21:34:32 EST
Ok, I have added the 'noathlon' option, I will let you know how it goes. If the
system stays up for more than 3 days I would say it is solved. :)
Btw, I read another bug report mentioning that the noathlon option disables some
fast memory copying routine (or something like that)... does it have any other
effects other than that? If it does, would I be better off with just a i686 kernel?

Also, my bug report is very similiar to bug 54931 so maybe you should mark it as
a dublicate. Sorry, I didn't see the other one until I submitted this one.
Comment 3 Frank Worsley 2001-11-15 22:02:19 EST
Well, no dice, it happened again. After using the system for about 20 minutes.
I am not positive but it seems to happen almost always when I browse the net
with Galeon, could this be related?

Also, RH7.1 and Mandrake 8.1 both ran fine on this sytem without any problems,
the only thing that has changed between then and now that I can think off is:
1. i reformatted and moved to 7.2 which now uses ext3 and not ext2
2. i added a logitech wireless mouse and keyboard, connected via the USB port
3. i added an internal ide LiteOn cd-rw. I am using the idescsi module to use it
in Linux

Any more ideas?
Comment 4 Need Real Name 2001-11-16 22:38:38 EST
I had the exact same problem as you, but I'm using different hardware.  Here's
how I fixed it:

Turn off Gnome sound.  Yup.

/settings/multimedia/sound/soundforevents

When I first installed RH 7.2 from 7.1, my system would lock-up every 2-4 hours.
 Very annoying.  I used up2date to update everything and installed the new
kernel, but none of this helped at all.  While searching DejaNews, I seen a post
from someone else describing the same problem, and he suggested the above fix. 
I was pretty sceptical at first, but desperate.  Anyway, it worked!  I haven't
had a system freeze since, and that was a few weeks ago.

I'm using a Celeron with a Soundblaster Live!  Now mind you, the emu10k support
in 7.2 is absolutely horrible, with lotsa pops and clicks, so maybe that's why
disabling Gnome sound worked for me.  YMMV
Comment 5 Frank Worsley 2001-12-08 00:41:07 EST
Ok, I did as you suggested and disabled sound effects in Gnome. I have not had a
lockup since then!!!
It appears there is either a problem with Gnome sounds or the audio card driver.
I think it is pretty unlikely that an application will lockup the kernel so I
suspect there must be a driver problem.
What should I do? Can I help with debugging it somehow?
Comment 6 Need Real Name 2002-05-31 18:00:05 EDT
I am having the same problem, and would like to try disabling sound,
but when I go to that panel, the "Sounds for events" option is checked
and greyed out so that I cannot uncheck it.  How do I fix that?
Comment 7 Bugzilla owner 2004-09-30 11:39:16 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.