Bug 563368 - yum-builddep: UnboundLocalError local variable 'toActOn' referenced before assignment
yum-builddep: UnboundLocalError local variable 'toActOn' referenced before as...
Status: CLOSED DUPLICATE of bug 563457
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-09 19:10 EST by Till Maas
Modified: 2014-01-21 18:13 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-10 05:18:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Till Maas 2010-02-09 19:10:08 EST
Description of problem:
yum-builddep gtranslator-1.9.7-1.fc13.src.rpm
Geladene Plugins: auto-update-debuginfo, presto
Found 17 installed debuginfo package(s)
Enabling fedora-debuginfo: Fedora 12 - x86_64 - Debug
Lese Repository-Metadaten aus lokalen Dateien ein
Enabling rpmfusion-nonfree-debuginfo: RPM Fusion for Fedora 12 - Nonfree - Debug
Lese Repository-Metadaten aus lokalen Dateien ein
Enabling livna-debuginfo: rpm.livna.org for 12 - x86_64 - Debug
Lese Repository-Metadaten aus lokalen Dateien ein
Enabling rpmfusion-free-updates-debuginfo: RPM Fusion for Fedora 12 - Free - Updates Debug
Lese Repository-Metadaten aus lokalen Dateien ein
Enabling rpmfusion-free-debuginfo: RPM Fusion for Fedora 12 - Free - Debug
Lese Repository-Metadaten aus lokalen Dateien ein
Enabling updates-debuginfo: Fedora 12 - x86_64 - Updates - Debug
Lese Repository-Metadaten aus lokalen Dateien ein
Enabling rpmfusion-nonfree-updates-debuginfo: RPM Fusion for Fedora 12 - Nonfree - Updates Debug
Lese Repository-Metadaten aus lokalen Dateien ein
Traceback (most recent call last):
  File "/usr/bin/yum-builddep", line 196, in <module>
    util = YumBuildDep()
  File "/usr/bin/yum-builddep", line 64, in __init__
    self.main()
  File "/usr/bin/yum-builddep", line 93, in main
    self.get_build_deps(opts)
  File "/usr/bin/yum-builddep", line 173, in get_build_deps
    for srpm in toActOn:
UnboundLocalError: local variable 'toActOn' referenced before assignment


Version-Release number of selected component (if applicable):
yum-utils-1.1.25-1.fc12


How reproducible:
always

Steps to Reproduce:
1.yum-builddep gtranslator-1.9.7-1.fc13.src.rpm
  
Actual results:
UnboundLocalError

Expected results:
Should install builddeps

Additional info:
abrt did not catch this :-/
Comment 1 Jiri Moskovcak 2010-02-10 04:14:11 EST
Till,
I guess you run this command under root and in this case ordinary users can't see it, you need to run abrt-gui as root.
Comment 2 Till Maas 2010-02-10 05:18:20 EST

*** This bug has been marked as a duplicate of bug 563457 ***

Note You need to log in before you can comment on or make changes to this bug.