Bug 56367 - kickstart installation crashes on --lba32
Summary: kickstart installation crashes on --lba32
Status: CLOSED DUPLICATE of bug 53923
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-11-16 08:29 UTC by Holger Schurig
Modified: 2007-04-18 16:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-21 09:42:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Holger Schurig 2001-11-16 08:29:42 UTC
Description of Problem:
When anaconda does a kickstart installation that contains --lba32, it will
stop
installation and display a python backtrace

Version-Release number of selected component (if applicable):
as on the RH 7.2 CD

Steps to Reproduce:
1.  install RH 7.2 manually and select LBA 32
2.  reboot after the installation, copy the anaconda-ks.cfg file to a
floppy,
it will contain a line like
bootloader --lba32 --md5pass=$1$TJkdpp:u$2/8NA9WAkbj3KNSrt5Uz61
3.  remove some comment lines
4.  use this to kickstart (I used it for a DHCP/NFS based auto-install)

Actual Results:
anaconda will crash and produce a python backtrace, telling me that --lba32
is not supported. The line in question is 219 in doBootLoader, which only
knows
about 'append=', 'location=', 'uselilo' and '--lba32'. I would say that the
'-- is
superfluous!

Expected Results:
a working installation, of course ...

Comment 1 Brent Fox 2001-11-20 21:46:27 UTC
Can you attach the kickstart file that anaconda produced?

Also, did you select to use LILO instead of GRUB in the installer?

Comment 2 Holger Schurig 2001-11-21 09:42:24 UTC
Sorry, I don't have this kickstart file anymore.

However, it's easy to reproduce. Just make a manual installation,
select lba32 (I also kept Grub) and you will get a anaconda-ks.cfg file
that will make the autoinstallation crash. And you can just take any kickstart
file and add --lba32 to the bootloader line.

However, I doubt that you have to go that far, because I have already
found the bug for you. Look at the sourcecode, all entries are of the
form 'text', but the lba32 option has two additional dashes in in front
of it: '--text'. No other option has this, so that must be the error.

Comment 3 Jeremy Katz 2002-01-16 20:25:11 UTC

*** This bug has been marked as a duplicate of 53923 ***


Note You need to log in before you can comment on or make changes to this bug.