Bug 563728 - Krunner does not appear when I press Alt-F2
Krunner does not appear when I press Alt-F2
Status: CLOSED DUPLICATE of bug 566061
Product: Fedora
Classification: Fedora
Component: soprano (Show other bugs)
All Linux
low Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
Depends On:
Blocks: kde-4.4
  Show dependency treegraph
Reported: 2010-02-10 18:10 EST by Peter Hedlund
Modified: 2010-02-16 21:07 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2010-02-11 09:47:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Peter Hedlund 2010-02-10 18:10:20 EST
Description of problem: http://lists.kde.org/?l=kde&m=126584264104700&w=2 describes problem, probable cause and workaround

Version-Release number of selected component (if applicable): 4.4.0

How reproducible: Always

Steps to Reproduce:
1. Press Alt+F2
Actual results: None

Expected results: KRunner input widget

Additional info:
Comment 1 Kevin Kofler 2010-02-10 19:17:34 EST
Uh, our KDE 4.4.0 builds should be already built against Soprano 2.4.0, so the hypothesis of this being due to building against 2.3.73 and running against 2.4.0 looks wrong to me.

Can you please post the output of:
rpm -q kdelibs kdebase-workspace soprano
Comment 2 Peter Hedlund 2010-02-10 20:21:32 EST

I see this on two machines, both x86_64.
Comment 3 Kevin Kofler 2010-02-10 20:55:04 EST
Hmmm, those packages (and kdebase-runtime-4.4.0-2.fc12) in kde-redhat were indeed built against 2.3.73. This should be better with:
from Koji which were built against soprano-2.4.0.
Comment 4 Kevin Kofler 2010-02-11 07:11:40 EST
Looks like that's not the issue, thomasj_ said on IRC that updating those packages from Koji didn't help.
Comment 5 Kevin Kofler 2010-02-11 08:43:32 EST
Can you please retest with soprano-
(Rex also pushed it to kde-unstable.)
Comment 6 Kevin Kofler 2010-02-11 09:47:05 EST
As upstream says this is fixed in soprano,, I'm just going to close this.
Comment 7 Peter Hedlund 2010-02-11 09:47:42 EST

sudo yum update with kde-unstable.
logged out and in again.
Pressed Alt+F2 and KRunner appeared.

Seems to be resolved.

Current packages:
Comment 8 Kevin Kofler 2010-02-11 09:50:30 EST
Thanks for the confirmation.
Comment 9 Kevin Kofler 2010-02-16 21:07:15 EST
Let's make it clear that this and the other 2 Soprano-induced issues are all duplicates of the same (fixed) bug.

*** This bug has been marked as a duplicate of bug 566061 ***

Note You need to log in before you can comment on or make changes to this bug.