Bug 563927 - Potential for deadlock when snapshots are taken of mirrors
Potential for deadlock when snapshots are taken of mirrors
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: lvm2 (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Jonathan Earl Brassow
Corey Marthaler
:
Depends On: 563924
Blocks: 756082
  Show dependency treegraph
 
Reported: 2010-02-11 10:32 EST by Jonathan Earl Brassow
Modified: 2013-02-21 03:07 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Known Issue
Doc Text:
Known Issue: Due to the limitations of the LVM 'mirror' segment type, it is possible to encounter a deadlock situation when snapshots are created of mirrors. The deadlock can occur if snapshot changes (e.g. creation, resizing or removing) happen at the same time as a mirror device failure. In this case, the mirror blocks I/O until LVM can respond to the failure, but the snapshot is holding the LVM lock while trying to read the mirror. If the user wishes to use mirroring and take snapshots of those mirrors, then it is recommended to use the 'raid1' segment type for the mirrored logical volume instead. This can be done by adding the additional arguments '--type raid1' to the command that creates the mirrored logical volume, as follows: ~> lvcreate --type raid1 -m 1 -L 1G -n my_mirror my_vg
Story Points: ---
Clone Of: 563924
Environment:
Last Closed: 2013-02-21 03:07:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 8 Jonathan Earl Brassow 2012-10-15 13:11:01 EDT
This bug will never be completely fixed WRT the 'mirror' segment type and snapshots.  However, 'raid1' can be used in place of 'mirror' and does not suffer from this issue.

Thus, this becomes a documentation and awareness issue.  I am marking this bug as MODIFIED, although that is not technically correct.  I don't want to CLOSE the bug without the release note stating that users should use the alternative.

It could be argued that LVM should warn users if snapshots are attempted on 'mirror's and suggest 'raid1' instead...
Comment 12 Peter Rajnoha 2012-10-19 07:46:12 EDT
Doc only bug, this should appear as a "Known Issue" item in the 6.4 documentation.
Comment 16 errata-xmlrpc 2013-02-21 03:07:35 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0501.html

Note You need to log in before you can comment on or make changes to this bug.