This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 563946 - UnboundLocalError: local variable 'toActOn' referenced before assignment
UnboundLocalError: local variable 'toActOn' referenced before assignment
Status: CLOSED DUPLICATE of bug 563457
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-11 11:07 EST by Mike Rich
Modified: 2014-01-21 18:13 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-12 10:57:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mike Rich 2010-02-11 11:07:19 EST
Description of problem:
Attempting to build dependencies for a standard f12 source rpm (in my case php) results in an UnboundLocalError.
------------------
[root@localhost SRPMS]# yum clean all
Loaded plugins: refresh-packagekit
Cleaning up Everything

[root@localhost SRPMS]# yum-builddep --disablerepo=* --enablerepo=fedora* --enablerepo=updates* php-5.3.1-1.fc12.src.rpm 
Loaded plugins: refresh-packagekit
fedora/metalink                                 |  19 kB     00:00     
fedora                                          | 4.2 kB     00:00     
fedora/primary_db                               | 9.7 MB     00:05     
updates/metalink                                |  13 kB     00:00     
updates                                         | 4.4 kB     00:00     
updates/primary_db                              | 3.2 MB     00:01     
Traceback (most recent call last):
  File "/usr/bin/yum-builddep", line 196, in <module>
    util = YumBuildDep()
  File "/usr/bin/yum-builddep", line 64, in __init__
    self.main()
  File "/usr/bin/yum-builddep", line 93, in main
    self.get_build_deps(opts)
  File "/usr/bin/yum-builddep", line 173, in get_build_deps
    for srpm in toActOn:
UnboundLocalError: local variable 'toActOn' referenced before assignment

[root@localhost SRPMS]# rpm -qa rpm* yum* | sort
rpm-4.7.2-1.fc12.i686
rpm-build-4.7.2-1.fc12.i686
rpm-devel-4.7.2-1.fc12.i686
rpmdevtools-7.5-1.fc12.noarch
rpm-libs-4.7.2-1.fc12.i686
rpm-python-4.7.2-1.fc12.i686
yum-3.2.25-1.fc12.noarch
yum-metadata-parser-1.1.2-14.fc12.i686
yum-utils-1.1.25-1.fc12.noarch


Version-Release number of selected component (if applicable):
1.1.25-1.fc12.noarch

How reproducible:
Attempt to build php from its standard source rpm

Steps to Reproduce:
1.yumdownloader --source php
2.yum clean all
3.yum-builddep php-5.3.1-1.fc12.src.rpm
  
Actual results:
UnboundLocalError: local variable 'toActOn' referenced before assignment

Expected results:
Dependencies built for srpm to enable a rebuild of said srpm
Comment 1 Tim Lauridsen 2010-02-12 10:57:53 EST

*** This bug has been marked as a duplicate of bug 563457 ***

Note You need to log in before you can comment on or make changes to this bug.