Bug 56427 - ifup ignores static routes for isdn devices
Summary: ifup ignores static routes for isdn devices
Status: CLOSED DUPLICATE of bug 59968
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts   
(Show other bugs)
Version: 7.2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-11-17 19:39 UTC by Bernd Bartmann
Modified: 2014-03-17 02:24 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-25 05:59:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bernd Bartmann 2001-11-17 19:39:04 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [de] (X11; U; Linux 2.4.9-13 i686)

Description of problem:
Static routes for isdn devices (set in /etc/sysconfig/static-routes) are
not set by /sbin/ifup because ifup calls:

OTHERSCRIPT="/etc/sysconfig/network-scripts/ifup-${DEVICETYPE}" 
                                                                                                                                   
if [ -x ${OTHERSCRIPT} ]; then
	exec ${OTHERSCRIPT} ${CONFIG} $2
fi     

and exec never returns to the ifup script. So ifup-post and ifup-routes are
never called for isdn interfaces.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. create an isdn interface
2. set a static route via this isdn interface
3. try "/sbin/ifup device" where device is your isdn device
4. try "route -n" and verify that the static route via this isdn interface
was not set by /sbin/ifup
	

Additional info:

Comment 1 Bill Nottingham 2002-08-21 05:34:34 UTC

*** This bug has been marked as a duplicate of 59968 ***


Note You need to log in before you can comment on or make changes to this bug.