Bug 56467 - PPP is missing the pppoatm.so plugin
PPP is missing the pppoatm.so plugin
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: ppp (Show other bugs)
7.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
Aaron Brown
: FutureFeature
: 59376 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-19 08:25 EST by Zarjazz
Modified: 2007-04-18 12:38 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-13 05:33:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zarjazz 2001-11-19 08:25:56 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

Description of problem:
The ppp package does not contain /usr/lib/pppd/plugins/pppoatm.so which 
makes PPPoA setup for UK ADSL users much more difficult. The current fix 
is to remove the RedHat ppp package and install the rpm from 
http://sourceforge.net/project/showfiles.php?group_id=23818

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. rpm -ql ppp | fgrep plugins
2.
3.
	

Additional info:
Comment 1 Need Real Name 2003-02-19 20:54:12 EST
Any chance of this being included in 8.1? I too have to use the sourceforge RPM
and up2date does not like this :) 
Duncan Sands is making good progress with the kernel mode drives for this modem;
http://linux-usb.sourceforge.net/SpeedTouch/
It's in the 2.5 series and there's rumours of a backport. This driver requires
ppppoa and the speedtouch modem is the default ADSL modem supplied by BT in the
UK, hence I think there will be increase in requests for this feature.

Mark

Comment 2 Harald Hoyer 2003-02-20 05:50:24 EST
*** Bug 59376 has been marked as a duplicate of this bug. ***
Comment 3 Danilo Aghemo 2003-04-11 15:22:16 EDT
I have an internal ADSL PCI board from Traverse (http://www.traverse.com.au/). 
I'm not required to use the PPPOA plugin with PPP, since I can connect 
with "pppd call adsl". But my problem is: how can I have a valid ifcfg-ppp0 
startup script so that my system can be brought on-line after a reboot?
RH8.0 is definitely missing PPPOA support... what's the best way to have it 
working?
Comment 4 John Levon 2003-09-04 01:34:08 EDT
FYI: both 2.4 and 2.6 now include the kernel speedtouch driver which requires
this plugin (along with the kernelside pppoatm). The USB speedtouch is
an extremely common modem for DSL users in the UK, it would be nice to see
"drop the firmware in and go" support in Red Hat.
Comment 5 Giacomo Magnini 2003-11-12 09:49:36 EST
FYI: even Fedora Core 1 shipped without such plugin, but *with* the
speedtch driver module compiled! What's the use of it? Without the
plugin the speedtch driver is useless (at least for ATM, dunno about
PPPoE)... Please, either ship a newer version of ppp or save space
(and compile time) by removing the speedtch driver... Obviuosly I hope
you'll follow the first suggestion (even in Italy there are many USB
speedtouch users), but choice's not mine. Having to replace the
shipped ppp can lead to many more troubles, and it is not as easy as a
./configure && make...
Comment 6 Alex Hornby 2003-12-20 06:07:59 EST
Given that in the UK (and the rest of the EU?) most ADSL is delivered
by PPP over ATM this is a fairly large omission.

I know the US mostly uses pppoe for broadband - but what about some
support for the rest of us - hell take it further and allow pppoa uses
to configure their connections with the "Internet Configuration
Wizard" tool!
Comment 7 Alex Hornby 2003-12-20 06:14:55 EST
Forgot to mention - I'm using Fedora Core 1, so its not like I'm using
an old distro.
Comment 8 Tim Mortlock 2004-01-02 06:37:20 EST
I'm a newbie using Fedora Core 1 and the lack of pppoatm.so is 
causing me big headaches... I can see why people are still put off 
Linux... I've spent days trying to get this working...
Comment 9 Alex Hornby 2004-01-03 10:31:13 EST
Mortlock, Timothy wrote:

> Sorry to e-mail direct (is this OK to do from Bugzilla?), but I was
wondering if you could give a newbie any pointers on how to get
pppoatm working on a UK broadband account. Its the lack of ppoatm.so
that seems to be causing me headaches at the moment...
>  
> Thanks,
>  
> Tim


Yeah, its a right pain. At the moment I'm working around it with some
user space drivers from http://speedtouch.sourceforge.net/ - these
avoid the need for pppoatm.o by presenting a teminal interface to the
non-atm aware pppd.

I'd rather use the kernel driver, but I don't fancy messing with my
ppp daemon and the accompanying yum/apt conflicts needed to install
pppoatm.o myself (I did it on my last RH9 install and it was quite a
big hassle I recall).

I've replied in a bugzilla follow-up just in case anyone else needs a
pointer to the user-space workaround.

Alex.
Comment 10 Giacomo Magnini 2004-01-31 11:55:57 EST
Actually you *can* use the FC supplied driver using speedbudle and
following the instructions given here:
http://www.4p8.com/eric.brasseur/speedbundle_fedora.html
This involves getting rid of ppp and rebuilding it: not very
user-friendly.
Comment 11 Thomas Woerner 2004-08-13 05:33:39 EDT
Please verify this with a newer version of Red Hat Enterprise Linux or Fedora
Core and reopen it against the new version if it still occurs.

Closing as "not a bug" for now.

Note You need to log in before you can comment on or make changes to this bug.