Bug 59376 - RFE: No support for PPPoA ADSL users
RFE: No support for PPPoA ADSL users
Status: CLOSED DUPLICATE of bug 56467
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-06 12:58 EST by Cedric Maion
Modified: 2007-04-18 12:39 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:48:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Cedric Maion 2002-02-06 12:58:44 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.0.2 (X11; Linux i686; U;) Gecko/20011226

Description of problem:
Support is missing for PPPoA ADSL users.
Also missing pppoatm.so plugin for ppp (see another open bug for this one)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Try to use neat to setup a PPPoA ADSL connexion! Not listed.
2.
3.
	

Actual Results:  No way to setup my ADSL cnx.

Expected Results:  Support for my ADSL cnx.

Additional info:

I own an Alcatel Speed Touch USB ADSL modem, provided by France Telecom for use
with its ADSL service (Wanadoo).

- Alactel Speed Touch support is not included in RH7.2 (Mandrake does include
support, but you've to add a closed source binary by yourself)

- pppoatm.so plugin for ppp is missing in RH7.2

- as of kernel-2.4.9-13, PPP over ATM is correctly included wrt the kernel


To make my modem work under RH7.2, I had to:
- get sarlib-0.2.4 (ATM support lib), speedtouch-1.5.tar (kernel module),
speedmgmt.tar.gz (this last one is closed source IIRC)
- compile sarlib and speedtouch
- install speedmgmt.tar.gz and speedtouch kernel module
- include the correct line in /etc/hotplug/usb.usermap
- add a modprobe -k pppoatm in /etc/hotplug/usb/speedtouch, plus a sleep 3
before starting speedmgmt

Then for the ADSL cnx:
- downgrade ppp to a one including pppoatm.so plugin
- create /etc/ppp/peers/ppp0 with:
lock
defaultroute
noipdefault 
noauth 
passive
asyncmap 0
lcp-echo-interval  2
lcp-echo-failure   7
name <username>
user <username>
usepeerdns

plugin /usr/lib/pppd/plugins/pppoatm.so
8.35 
- create a /etc/sysconfig/network-scripts/ifcfg-ppp0 with
DEVICE=ppp0
NAME=ADSL
USERCTL=true
ONBOOT=no
PERSIST=no
DEFROUTE=yes
DEMAND=no
DEVNAME=ppp0
- change /etc/sysconfig/network-scripts/ifdown-post to remove the following line:
rm -f /etc/ppp/peers/$DEVICE


Conclusion: PPPoA ADSL could be better supported!

Thanks,

Cedric Maion
Comment 1 Trond Eivind Glomsrxd 2002-02-06 16:26:26 EST
Which version of redhat-config-network are you using?
Comment 2 Cedric Maion 2002-02-07 12:47:34 EST
redhat-config-network-0.9.10-2 (stock RH7.2 I think)
Comment 3 Harald Hoyer 2002-06-26 09:58:04 EDT
we only have pppoe ... not pppoA (over ATM)! so it is a RFE..
Comment 4 Need Real Name 2003-02-19 20:46:34 EST
Dupe of bug 56467 ?
Comment 5 Harald Hoyer 2003-02-20 05:49:50 EST
yep
Comment 6 Harald Hoyer 2003-02-20 05:50:22 EST

*** This bug has been marked as a duplicate of 56467 ***
Comment 7 Danilo Aghemo 2003-04-11 15:26:46 EDT
I have an internal ADSL PCI board from Traverse (http://www.traverse.com.au/). 
I'm not required to use the PPPOA plugin with PPP, since I can connect 
with "pppd call adsl". But my problem is: how can I have a valid ifcfg-ppp0 
startup script so that my system can be brought on-line after a reboot?
RH8.0 is definitely missing PPPOA support... what's the best way to have it 
working? I don't think this is a duplicate of 56467, since in my case 
pppoatm.so is not needed in my case.
Comment 8 Red Hat Bugzilla 2006-02-21 13:48:25 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.