This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 564767 - FTBFS gshutdown-0.2-6.fc12: ImplicitDSOLinking
FTBFS gshutdown-0.2-6.fc12: ImplicitDSOLinking
Status: CLOSED DUPLICATE of bug 599784
Product: Fedora
Classification: Fedora
Component: gshutdown (Show other bugs)
13
All Linux
high Severity high
: ---
: ---
Assigned To: Xavier Lamien
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
: Triaged
Depends On:
Blocks: 564245 583274
  Show dependency treegraph
 
Reported: 2010-02-13 11:51 EST by FTBFS
Modified: 2011-04-07 05:37 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-07 05:37:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
root.log (454.18 KB, text/plain)
2010-02-13 11:51 EST, FTBFS
no flags Details
build.log (20.06 KB, text/plain)
2010-02-13 11:51 EST, FTBFS
no flags Details
mock.log (952 bytes, text/plain)
2010-02-13 11:51 EST, FTBFS
no flags Details
root.log (658.72 KB, text/plain)
2010-02-13 11:51 EST, FTBFS
no flags Details
build.log (19.43 KB, text/plain)
2010-02-13 11:51 EST, FTBFS
no flags Details
mock.log (961 bytes, text/plain)
2010-02-13 11:51 EST, FTBFS
no flags Details
gshutdown (303 bytes, text/plain)
2010-05-12 15:06 EDT, Charley Wang
no flags Details

  None (edit)
Description FTBFS 2010-02-13 11:51:22 EST
gshutdown-0.2-6.fc12.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
This failure is due to a change in the linker default behavior, which uncovered a fault in your package.  See http://fedoraproject.org/wiki/Features/ChangeInImplicitDSOLinking .
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2010-02-13 11:51:25 EST
Created attachment 391613 [details]
root.log

root.log for i386
Comment 2 FTBFS 2010-02-13 11:51:26 EST
Created attachment 391614 [details]
build.log

build.log for i386
Comment 3 FTBFS 2010-02-13 11:51:27 EST
Created attachment 391615 [details]
mock.log

mock.log for i386
Comment 4 FTBFS 2010-02-13 11:51:29 EST
Created attachment 391616 [details]
root.log

root.log for x86_64
Comment 5 FTBFS 2010-02-13 11:51:30 EST
Created attachment 391617 [details]
build.log

build.log for x86_64
Comment 6 FTBFS 2010-02-13 11:51:33 EST
Created attachment 391618 [details]
mock.log

mock.log for x86_64
Comment 7 Bug Zapper 2010-03-15 10:40:44 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Charley Wang 2010-05-12 15:06:18 EDT
Created attachment 413525 [details]
gshutdown

Hi,

I made a quick patch that fixes the ld error in gshutdown. It uses AC_CHECK_LIB which can be inefficient but will get this package building again.

If nobody objects, I can find someone to do a direct commit of this fix so that gshutdown will work in F-13.

-Charley
Comment 9 Xavier Lamien 2010-05-12 15:16:22 EDT
I will take care of this tomorrow.
Thanks for having taken time to do the patch.
Comment 10 Xavier Lamien 2010-05-13 10:46:23 EDT
Alright,
Added your patch however, was missing, the X linkers.
new release is on its way.
Comment 11 Charley Wang 2010-05-20 11:01:02 EDT
Thanks for taking a look! I don't see the new release in fedora-cvs yet, will test a rebuild when I do.

Thanks,

-Charley
Comment 12 Xavier Lamien 2010-06-15 05:28:04 EDT
yep, having some cvs issue which will be fix soonish.
Comment 13 Jan Klepek 2011-03-13 07:57:39 EDT
Hi,

Was this issue fixed and package pushed into testing/stable?
Comment 14 Caolan McNamara 2011-04-07 05:37:58 EDT

*** This bug has been marked as a duplicate of bug 599784 ***

Note You need to log in before you can comment on or make changes to this bug.