Bug 599784 - FTBFS gshutdown-0.2-6.fc12: ImplicitDSOLinking
Summary: FTBFS gshutdown-0.2-6.fc12: ImplicitDSOLinking
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gshutdown   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Xavier Lamien
QA Contact: Fedora Extras Quality Assurance
URL: http://linux.dell.com/files/fedora/Fi...
Whiteboard:
Keywords: Triaged
: 564767 (view as bug list)
Depends On:
Blocks: F14FTBFS
TreeView+ depends on / blocked
 
Reported: 2010-06-03 20:28 UTC by FTBFS
Modified: 2011-04-07 09:46 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-07 09:46:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
root.log (367.06 KB, text/plain)
2010-06-03 20:28 UTC, FTBFS
no flags Details
build.log (20.00 KB, text/plain)
2010-06-03 20:28 UTC, FTBFS
no flags Details
mock.log (970 bytes, text/plain)
2010-06-03 20:28 UTC, FTBFS
no flags Details
root.log (558.14 KB, text/plain)
2010-06-03 20:28 UTC, FTBFS
no flags Details
build.log (19.43 KB, text/plain)
2010-06-03 20:28 UTC, FTBFS
no flags Details
mock.log (901 bytes, text/plain)
2010-06-03 20:28 UTC, FTBFS
no flags Details

Description FTBFS 2010-06-03 20:28:15 UTC
gshutdown-0.2-6.fc12.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
This failure is due to a change in the linker default behavior, which uncovered a fault in your package.  See http://fedoraproject.org/wiki/Features/ChangeInImplicitDSOLinking .
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)

Comment 1 FTBFS 2010-06-03 20:28:18 UTC
Created attachment 419696 [details]
root.log

root.log for i386

Comment 2 FTBFS 2010-06-03 20:28:19 UTC
Created attachment 419697 [details]
build.log

build.log for i386

Comment 3 FTBFS 2010-06-03 20:28:20 UTC
Created attachment 419698 [details]
mock.log

mock.log for i386

Comment 4 FTBFS 2010-06-03 20:28:22 UTC
Created attachment 419699 [details]
root.log

root.log for x86_64

Comment 5 FTBFS 2010-06-03 20:28:23 UTC
Created attachment 419700 [details]
build.log

build.log for x86_64

Comment 6 FTBFS 2010-06-03 20:28:24 UTC
Created attachment 419701 [details]
mock.log

mock.log for x86_64

Comment 7 Bug Zapper 2010-07-30 11:50:42 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 8 Caolan McNamara 2011-04-07 09:37:58 UTC
*** Bug 564767 has been marked as a duplicate of this bug. ***

Comment 9 Caolan McNamara 2011-04-07 09:46:58 UTC
This has been lingering for quite a while, built as gshutdown-0.2-8.fc16 to stop me getting an email about it


Note You need to log in before you can comment on or make changes to this bug.