Bug 56477 - srpm won't rebuild
Summary: srpm won't rebuild
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-11-19 17:30 UTC by Jackie Meese
Modified: 2014-03-17 02:24 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-28 06:08:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jackie Meese 2001-11-19 17:30:04 UTC
Description of Problem:
srpm fails rebuild with "multiple target patterns"

Version-Release number of selected component (if applicable):
6.40-1

How Reproducible:
every time

Steps to Reproduce:
1. # rpm --rebuild initscripts-6.40-1.src.rpm

Actual Results:
cc  -O2 -march=i386 -mcpu=i686 -Wall -D_GNU_SOURCE `glib-config --cflags`
-c shvar.c -o shvar.o
cc  -o ppp-watch ppp-watch.o shvar.o /usr/lib/libglib.a
cc  -O2 -march=i386 -mcpu=i686 -Wall -D_GNU_SOURCE    consoletype.c   -o
consoletype
make[1]: Leaving directory `/usr/src/redhat/BUILD/initscripts-6.40/src'
(make -C po)
make[1]: Entering directory `/usr/src/redhat/BUILD/initscripts-6.40/po'
Makefile:17: *** multiple target patterns.  Stop.
make[1]: Leaving directory `/usr/src/redhat/BUILD/initscripts-6.40/po'
make: *** [all] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.79279 (%build)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.79279 (%build)


Expected Results:
correct recompile

Comment 1 Jackie Meese 2001-11-19 20:33:42 UTC
ok, seems to work a friend's machine, custom 2.4.13 kernel, RH 7.1

not a bug?  or is it still worth it?




Comment 2 Michael Schwendt 2001-11-21 17:56:33 UTC
Deja vu? Might be related to what Bero has asked in bug #56474 already.

Comment 3 Bill Nottingham 2001-11-28 06:08:20 UTC
hm, not sure. it works for me. Are you running any non-RH-7.2 packages? What
locale are you running in?

Comment 4 Bill Nottingham 2002-01-25 06:06:26 UTC
I cannot reproduce this here.


Note You need to log in before you can comment on or make changes to this bug.