Bug 56487 - time-udp hangs with xinetd-2.3.3-1
time-udp hangs with xinetd-2.3.3-1
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: xinetd (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
Brock Organ
:
: 59315 60768 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-19 16:17 EST by Darren Gamble
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-19 18:15:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Darren Gamble 2001-11-19 16:17:13 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

Description of problem:
time-udp does not appear to work properly with xinetd-2.3.3-1 .  After 
changing disable to "no" in the time-udp conf file and restarting xinetd, 
only one connection can be made.  Any further connections from any host 
time out until xinetd is restarted (which will once again allow only one 
connection).  

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Change "disable = no" in /etc/xinetd/time-udp and restart xinetd.
2. run "rdate -u localhost".  Note time is returned. 
3. run "rdate -u localhost" again.  Note connection tims out.
	

Actual Results:  Connection times out until xinetd is restarted.

Expected Results:  Time should have been returned.

Additional info:

time-udp works fine with xinetd-2.1.8.9pre11-1 (older version) and xinetd-
2001.10.30.tar.gz (a newer devel version)
Comment 1 Trond Eivind Glomsrxd 2001-11-19 18:15:32 EST
Reproduced. Debug time.
Comment 2 Trond Eivind Glomsrxd 2001-11-30 18:58:06 EST
Fixed in xinetd-2.3.4-0.1 (the 2001-11-29 snapshot), which you can find in
Rawhide shortly.
Comment 3 Trond Eivind Glomsrxd 2002-02-06 18:02:02 EST
*** Bug 59315 has been marked as a duplicate of this bug. ***
Comment 4 Trond Eivind Glomsrxd 2002-03-06 11:41:38 EST
*** Bug 60768 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.