Bug 59315 - UDP Time Protocol server quits after first request.
Summary: UDP Time Protocol server quits after first request.
Status: CLOSED DUPLICATE of bug 56487
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: xinetd   
(Show other bugs)
Version: 7.2
Hardware: athlon Linux
medium
medium
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-02-05 03:54 UTC by David Vos
Modified: 2007-04-18 16:39 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-05 03:56:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Code file demonstrating problem. (2.97 KB, text/plain)
2002-02-05 03:56 UTC, David Vos
no flags Details

Description David Vos 2002-02-05 03:54:27 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2.1) Gecko/20010901

Description of problem:
If a program following RFC 868 connects to the time server via udp
(port 37), the server responds correctly after the first request.
After that, the server no longer responds to requests.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
I have attached a sample C program that demonstrates the problem.
[dvos12@qwerty 9.1]$ gcc -o t time.c
[dvos12@qwerty 9.1]$ ./t localhost



Actual Results:  UDP timeout.  Trying TCP.
Mon Feb  4 22:43:31 2002

Expected Results:  Mon Feb  4 22:43:31 2002

Additional info:

This is my /etc/xinetd.d/time-udp

service time
{
        type            = INTERNAL UNLISTED
        id              = time-dgram
        socket_type     = dgram
        protocol        = udp
        user            = root
        wait            = yes
        disable         = no
        port            = 37
}

Comment 1 David Vos 2002-02-05 03:56:19 UTC
Created attachment 44477 [details]
Code file demonstrating problem.

Comment 2 Trond Eivind Glomsrxd 2002-02-06 23:02:07 UTC

*** This bug has been marked as a duplicate of 56487 ***


Note You need to log in before you can comment on or make changes to this bug.