Bug 56493 - X11 broken for ATI Radeon after RH7.2 upgrade
X11 broken for ATI Radeon after RH7.2 upgrade
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.2
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-19 18:20 EST by Geoffrey S. Knauth
Modified: 2007-04-18 12:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-18 10:24:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
most recent /var/log/XFree86.0.log, after startx puts garbage on screen (25.03 KB, text/plain)
2001-11-20 14:03 EST, Geoffrey S. Knauth
no flags Details
/etc/X11/XF86Config-4 created by Xconfigurator (1.79 KB, text/plain)
2001-11-20 14:07 EST, Geoffrey S. Knauth
no flags Details
output from "uname -a" and "rpm -qa | grep kernel" (383 bytes, text/plain)
2001-11-20 14:12 EST, Geoffrey S. Knauth
no flags Details

  None (edit)
Description Geoffrey S. Knauth 2001-11-19 18:20:26 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.7-10 i686)

Description of problem:
Xconfigurator and/or startx no longer work after RH7.2 upgrade, using the
ATI Radeon card.  Starting the X11 server (or testing it) produces a
screenful of colored snow, an X cursor you can move, but the keyboard is
dead and the machine has to be rebooted.  X11/XFree86 and the Radeon worked
fine under RH7.1.  I called into tech support (conf #I-2346541) but this
was one they couldn't solve although they saw the problem too.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  Upgrade from Redhat 7.1 to 7.2 with an ATI Radeon card.
2.  Try Xconfigurator or startx.
3.  When X11 tries to start up, your keyboard will go dead and the machine
will need rebooting.
	

Actual Results:  Machine hung up, machine requires reboot.

Expected Results:  X11 should have started up and I should have gotten a
Gnome desktop.

Additional info:
Comment 1 Mike A. Harris 2001-11-19 19:28:41 EST
ATI Radeon is my main card on 4 machines.  It is the most tested piece
of video hardware.  I'm not sure what the problem you are having is,
as the Radeon's very much work for me.  While a bug is not out of the
question, I much more highly suspect a misconfiguration of some kind.

Please make sure that the xfs font server is configured, and that it
is running properly.  If you still have problems, please look in your
X server log /var/log/XFree86.0.log for clues as to what might be
wrong.


> I called into tech support (conf #I-2346541) but this was one they
> couldn't solve although they saw the problem too.

I'm curious as to who in tech support could reproduce this, as it is
the first time it has ever been reported.  I'm skeptical that it is
a bug, but I will look deeper if you provide me with more information.

Please attach your XF86Config-4 and X server logs using the link below,
as well as the output of "uname -a" and "rpm -qa |grep kernel".


Comment 2 Geoffrey S. Knauth 2001-11-20 14:03:43 EST
Created attachment 38067 [details]
most recent /var/log/XFree86.0.log, after startx puts garbage on screen
Comment 3 Geoffrey S. Knauth 2001-11-20 14:07:12 EST
Created attachment 38068 [details]
/etc/X11/XF86Config-4 created by Xconfigurator
Comment 4 Geoffrey S. Knauth 2001-11-20 14:12:11 EST
Created attachment 38069 [details]
output from "uname -a" and "rpm -qa | grep kernel"
Comment 5 Mike A. Harris 2001-11-20 20:31:34 EST
Please update to the latest official erratum kernel first, which
at this time is 2.4.9-13.  If you still have trouble, attach new
X server log, and also your /var/log/messages.
Comment 6 Need Real Name 2001-11-30 13:15:16 EST
I am experiencing VERBATIM the exact problems as described by gknauth@bbn.com...

>I'm curious as to who in tech support could reproduce this, as it is
>the first time it has ever been reported. 

*Please refer to bug 56320 in which I reported this on the 17th of November*

If this is a misconfiguration, it is because of the setup installation.  It
worked fine during install for X, but as soon as system was live, no more X.  
Comment 7 Need Real Name 2001-12-04 14:50:47 EST
...And I'm seeing a similar problem.
X/gnome work okay, but after leaving xstart, the console promptly turns to
gibberish with all sorts of non-text characters.
Sometimes am still able to shut the system down ("init 0").  Other times, I get
no response whatsoever to typing.
I'm using the Radeon ATI "generic" driver, even though it's an AGP card.
Comment 8 Mike A. Harris 2002-01-25 04:59:07 EST
gknauth@bbn.com:  Can you please also attach a copy of the output of
cat /proc/cpuinfo please, and your /var/log/messages from immediately
after a crash.

mknight@hushmail.com:  You'll also note that on your bug #56320 which
you reported back in november, that I have requested you provide me
with more information less than two hours after your last entry.  You
have not supplied me with this information, and so I have not (and will
not until you do) looked into your report further.

So far, all ATI Radeon bug reports that we have had reported have been
one of either:

1) Buggy VIA chipet and/or buggy BIOS on VIA motherboard
   Solution:  Upgrade the BIOS to the latest flashrom available, upgrade
              kernel to latest Official that Red Hat kernel erratum.
              

2) Buggy AMD 760 series chipset/motherboard
   Solution:  Upgrade BIOS to latest version and upgrade kernel to latest
              Official that Red Hat kernel erratum.

3) AMD Athlon CPU PSE/AGP bug that was recently discovered
   Solution:  Upgrade your kernel to the latest official Red Hat erratum
              kernel.  Make sure your kernel boots with the "nopentium" option

There are also other hardware issues.  I suggest everyone experiencing
Radeon problems read the mailing list archives of our mailing lists,
as well as xpert@xfree86.org.   I can assure you that very very few
people ever report Radeon lockup problems, and in all cases that we
have resolved, the problem has turned out to be buggy hardware, or
kernel bugs in DRM or the console locking code - which have been long
since fixed.


Comment 9 Mike A. Harris 2002-02-09 10:57:44 EST
Nobody seems to be in a race to get this looked into...

Is this problem a non-problem now?  All of my Radeon cards work perfectly
fine with all released versions and beta version of XFree86 4.0.2 and up
with 2D, and 4.1.0 and up with 3D, including the rawhide versions, so
if someone is having a problem, I need details, or I'm going to have
to chalk it off to being an incompatible hardware combination as I
can't test it further due to inability to reproduce.
Comment 10 Geoffrey S. Knauth 2002-02-13 05:17:30 EST
I have yet to upgrade the XFree86 to 4.1.0 on the affected system since I'm not sure it's a clean RPM upgrade and time has been very precious, so precious that I 
restricted my Linux work to a different machine without a Radeon card.

The affected machine has lately only been run from its WinNT4 disk because I was tasked to crank out hundreds of pages of tech docs in MS Word (yes I know that's 
sad, but a dozen people's jobs depend on it).  So you're right, I have not been in a rush to get this fixed because getting the machine with the Radeon to work under 
Linux is considered play and not work right now.

What's the quickest way to upgrade to the XFree 4.1.0 you mentioned [Mike H.] ?  I just took a look at http://www.xfree86.org/4.2.0/Install.html and it seems I need to 
download 12 files and run a script.  That in itself doesn't sound terrible but I wonder why they don't use RPMs or have a tgz with the 12 things you need.  If you think 
the Xinstall.sh is a routine (relatively painless) operation I'll be happy to give it a try.  I know I took a look at that the first time and thought, "Just what I need, lost hours 
getting and building pieces, answering questions and tweaking configurations."
Comment 11 Geoffrey S. Knauth 2002-02-18 10:24:45 EST
Over the weekend I upgraded to XFree 4.2.0 and the fundamental problem went away.  That is, X11 basically works again, instead of locking up the 
local keyboard and painting garbage on the screen.

The only problem I had after that was, after XFree 4.2.0 installed itself, it left me with a vanilla (really old-fashioned) X11 login.  Even though Gnome 
still seemed to be there, it wasn't coming up.  I did some tweaking of config files (I forget specifically what I did now), but then the Gnome didn't look 
the way I expected it did (it too seemed old), so I went to the Ximian website and reinstalled Gnome.  Maybe that was overkill, but at least my 
desktop has the "new" Gnome look (thin menus at the top, buttons at the bottom that show launched applications and showing all Emacsen, for 
example, under one Emacs button).

Note You need to log in before you can comment on or make changes to this bug.