Bug 56519 - Migration to ext3 failed when upgrading to Red Hat Linux 7.2
Summary: Migration to ext3 failed when upgrading to Red Hat Linux 7.2
Status: CLOSED DUPLICATE of bug 56987
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-11-20 14:58 UTC by Toralf
Modified: 2007-04-18 16:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-01 21:26:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda dump (69.27 KB, text/plain)
2001-11-20 15:01 UTC, Toralf
no flags Details
Anaconda dump from boot loader installation (107.28 KB, text/plain)
2001-11-20 15:13 UTC, Toralf
no flags Details
/etc/fstab after "ext2" has been replaced by "ext3" for "/" and "/boot" (1.41 KB, text/plain)
2001-12-05 09:11 UTC, Toralf
no flags Details

Description Toralf 2001-11-20 14:58:33 UTC
Description of Problem:
Migration of existing file systems to "ext3" failed when upgrading to Red
Hat Linux 7.2.

Version-Release number of selected component (if applicable):


How Reproducible:
Every time.

Steps to Reproduce:
1. Boot installer from CD or floppy.
2. Fill in the correct details; I'm assuming you know what to do.
3. Select "Upgrade Existing System" when asked for installation type.
4. Enable migration to "ext3" file system for "/" and "/boot".
5. Take the rest of the steps necessary to start installation.

Actual Results:
Anaconda dump.

Expected Results:
Installation starts

Additional Information:
Main board: Super Micro P6DBE
Disk: Seagate ST39102LW on Tekram DC-390U2W SCSI adapter.

Installation starts if file systems are _not_ marked for migration to ext3.

Comment 1 Toralf 2001-11-20 15:01:46 UTC
Created attachment 38023 [details]
Anaconda dump

Comment 2 Toralf 2001-11-20 15:10:50 UTC
When not marking filesystems for migration, installation of all packages was
successful, but I got another crash during boot loader installation. The system
subsequently wouln't boot, but I managed to get it up and running by creating
/boot/grub/grub.conf, then issuing /sbin/grub-install (after chroot to
/mnt/sysimage) in rescue mode.

Also not that e.g 'tune2fs -j /dev/sda6' failed with message
   The filesystem already has a journal.
The system started successfully after changing "ext2" to "ext3" in /etc/fstab,
then rebooting.

Comment 3 Toralf 2001-11-20 15:13:50 UTC
Created attachment 38024 [details]
Anaconda dump from boot loader installation

Comment 4 Michael Fulbright 2001-12-03 22:06:38 UTC
Please attach your /etc/fstab file.

Comment 5 Toralf 2001-12-05 09:11:43 UTC
Created attachment 39689 [details]
/etc/fstab after "ext2" has been replaced by "ext3" for "/" and "/boot"

Comment 6 Michael Fulbright 2002-02-13 03:19:08 UTC
Could you attach your original lilo.conf as well?

Comment 7 Toralf 2002-03-01 07:34:41 UTC
It's long gone, I'm afraid. There wasn't anything special about it, though; just
the default installed by anaconda modified for kernel updates.

Comment 8 Jeremy Katz 2002-03-06 23:05:34 UTC
Due to the fstsab not having all 6 fields

*** This bug has been marked as a duplicate of 56987 ***


Note You need to log in before you can comment on or make changes to this bug.