Bug 56987 - make fstab parsing more robust
make fstab parsing more robust
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
: FutureFeature
: 56519 57493 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-02 01:18 EST by Ron Gomes
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:48:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda crash output written to floppy disk (78.08 KB, text/plain)
2001-12-02 01:21 EST, Ron Gomes
no flags Details
Original /etc/fstab at the time of installation (1.72 KB, text/plain)
2001-12-03 15:36 EST, Ron Gomes
no flags Details

  None (edit)
Description Ron Gomes 2001-12-02 01:18:27 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.79 [en] (X11; U; Linux 2.4.9-12 i686)

Description of problem:
In upgrading a 7.1 installation to 7.2, anaconda repeatably crashes on a
hard-drive install with a "list index out of range" error just after
"Preparing RPM installation" and before any packages appear to have been
actually installed.  /etc/fstab is truncated and has to be manually
restored from backup or from fstab.rpmsave in order to boot the old system
afterward.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
ISO images downloaded from rufus.w3.org and placed on a VFAT file system on
a 2GB Jaz disk.  md5sums are correct.  Booted from a boot.img floppy and
proceeded with the installation as described, specifying a hard-drive
install and pointing it at the Jaz drive. 	

Actual Results:  Installation crashes and destroys /etc/fstab every time.

I saved to floppy disk the anacdump.txt file, the full version of which is
attached.  The first few lines of it (the traceback) are:

Traceback (innermost last):
  File "/usr/bin/anaconda", line 620, in ?
    intf.run(id, dispatch, configFileData)
  File "/usr/src/build/41637-i386/install//usr/lib/anaconda/text.py", line
408, in run
  File "/usr/src/build/41637-i386/install//usr/lib/anaconda/dispatch.py",
line 143, in gotoNext
  File "/usr/src/build/41637-i386/install//usr/lib/anaconda/dispatch.py",
line 208, in moveStep
  File "/usr/src/build/41637-i386/install//usr/lib/anaconda/packages.py",
line 554, in doInstall
  File "/usr/src/build/41637-i386/install//usr/lib/anaconda/fsset.py", line
692, in migratewrite
IndexError: list index out of range



Expected Results:  A proper upgrade to 7.2, presumably.

Additional info:

600 MHz Pentium III, ASUS P2-LS motherboard, SCSI installation.  System was
originally built in February 1999 with whatever version of RedHat was
current and has been upgraded one or more times since then (but OS was
never re-installed afresh).

System has valid RedHat installs on /dev/sda1 and /dev/sdb1 but the upgrade
is pointed at /dev/sda1.

I told the installer to use LILO rather then GRUB (but I expect the
installation didn't get far enough for that to matter).
Comment 1 Ron Gomes 2001-12-02 01:21:20 EST
Created attachment 39307 [details]
anaconda crash output written to floppy disk
Comment 2 Michael Fulbright 2001-12-03 15:27:29 EST
Please attach the original /etc/fstab file.
Comment 3 Ron Gomes 2001-12-03 15:36:00 EST
Created attachment 39488 [details]
Original /etc/fstab at the time of installation
Comment 4 Jeremy Katz 2001-12-03 15:41:12 EST
The last few lines of your fstab aren't really valid; you don't have the check
field options at the end of the lines (all of the /adisk1 mounts).  Changing
subject and marking as enhancement to make that parsing more robust.  The simple
workaround is to add 0 0 to the end of those lines (or other check interval if
desired).
Comment 5 Michael Fulbright 2001-12-17 15:23:47 EST
*** Bug 57493 has been marked as a duplicate of this bug. ***
Comment 6 Jeremy Katz 2002-03-05 17:04:59 EST
Fixed in CVS
Comment 7 Jeremy Katz 2002-03-06 18:05:29 EST
*** Bug 56519 has been marked as a duplicate of this bug. ***
Comment 8 Michael Fulbright 2002-04-04 15:48:20 EST
This line in my fstab fails:

/dev/sda1  /opt  ext3 default

It fails trying in line 1569 of fsset.py when its doing:

fields[4] = 0

and fields is

['/dev/sda1', '/opt', 'ext3', 'defaults']

Comment 9 Michael Fulbright 2002-04-04 15:59:57 EST
Katzj has a fix which works now.
Comment 10 Red Hat Bugzilla 2006-02-21 13:48:16 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.