Bug 56563 - dia unable to find fonts for builtin UML things
dia unable to find fonts for builtin UML things
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: dia (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
: 76851 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-20 19:46 EST by John M O'Donnell
Modified: 2007-04-18 12:38 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-12 08:10:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
example to create the bug described (1.77 KB, application/dia)
2001-11-20 19:48 EST, John M O'Donnell
no flags Details

  None (edit)
Description John M O'Donnell 2001-11-20 19:46:37 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2.1) Gecko/20010901

Description of problem:
running dia for a UML diagram with abstract classes does
not find the fonts it needs.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.dia james.dia
2.
3.
	

Actual Results:  three error message dialog boxes about missing fonts:

Warning no X Font for Helvetica-BoldOblique found,
using -adobe-courier-medium-r-normal-*-%d-*-*-*-*-*-*-*

same message also for fonts Helvetica-Bold, Courier-Oblique

Diagram is displayed all in one font - so I can't tell the difference
between an abstract class, and non abstract, and the same for functions.

Expected Results:  Class names should be bold, abstract class names should
be bold italic, abstract function names should be italic.

Additional info:

james.dia was created with dia on RH7.1, which worked.
(Many of the other bugs in that release are fixed in RH7.2,
but this font business makes it unusable for me.
Comment 1 John M O'Donnell 2001-11-20 19:48:17 EST
Created attachment 38165 [details]
example to create the bug described
Comment 2 Alexander Larsson 2001-11-20 20:34:47 EST
It does work for me at home. I'll take a closer look at it tomorrow at work.

I suspect it's some font-install issue or so.
Comment 3 Alexander Larsson 2001-11-21 15:06:07 EST
Works for me at work to.

What is the output of 
rpm -qa | grep -i font

And what language/locale do you run in?
Comment 4 John M O'Donnell 2001-11-21 15:58:19 EST
my machine is a clean RH 7.2 install, 

LANG=en_US
locale is default

I'm sure it's a font config problem, but I couldn't spot anything obvious.
my machine is a clean RH7.2 with official patches.  All other programs seem
to run great - although my .xsession-errors shows:
xmlencoding detect- iso-8859-1
don't know what program makes this.  Any way, the other font info is:

odonnell@sagerdell(pts/1)~$ rpm -qa | grep -i font
urw-fonts-2.0-12
XFree86-ISO8859-7-100dpi-fonts-1.0-10
ttfonts-ja-1.0-7
XFree86-ISO8859-15-100dpi-fonts-4.1.0-3
XFree86-KOI8-R-100dpi-fonts-1.0-6
chkfontpath-1.9.5-2
ttfonts-1.0-4
XFree86-75dpi-fonts-4.1.0-3
XFree86-ISO8859-7-Type1-fonts-1.0-10
XFree86-100dpi-fonts-4.1.0-3
tetex-fonts-1.0.7-30
XFree86-ISO8859-7-75dpi-fonts-1.0-10
XFree86-ISO8859-15-75dpi-fonts-4.1.0-3
ghostscript-fonts-5.50-3
Comment 5 Alexander Larsson 2001-11-26 12:38:46 EST
I don't understand it. I just installed the same fonts, and it works for me.

Can you try:
xfd -fn -adobe-helvetica-bold-o-normal-*-100-*-*-*-*-*-*-*

And see if it works?
Comment 6 John M O'Donnell 2001-11-26 13:29:54 EST
odonnell@sagerdell(pts/6)~$ xfd -fn \
-adobe-helvetica-bold-o-normal-*-100-*-*-*-*-*-*-*

Warning: Cannot convert string
"-adobe-helvetica-bold-o-normal-*-100-*-*-*-*-*-*-*" to type FontStruct
xfd:  no font to display
Comment 7 John M O'Donnell 2001-11-26 13:35:25 EST
but the following does display a font:

xfd -fn -adobe-helvetica-bold-o-normal-*-*-*-100-*-*-*-*-*

the font displayed is:
-Adobe-Helvetica-Bold-O-Normal--11-80-100-100-P-60-ISO8859-1

John.
Comment 8 Alexander Larsson 2001-11-26 14:17:55 EST
I wonder why it couldn't give a 100 pixel font?

Dia does that to get some metrics it can scale.
Comment 9 John M O'Donnell 2001-11-26 20:23:48 EST
Alex,

here's everything that I have that's close:

odonnell@sagerdell(pts/0)~/work$ xlsfonts -fn \       
-adobe-helvetica-bold-o-normal-*-100-*-*-*-*-*-*
-adobe-helvetica-bold-o-normal--10-100-75-75-p-60-iso10646-1
-adobe-helvetica-bold-o-normal--10-100-75-75-p-60-iso8859-1
-adobe-helvetica-bold-o-normal--10-100-75-75-p-60-iso8859-15
-adobe-helvetica-bold-o-normal--14-100-100-100-p-82-iso10646-1
-adobe-helvetica-bold-o-normal--14-100-100-100-p-82-iso8859-1
-adobe-helvetica-bold-o-normal--14-100-100-100-p-82-iso8859-15

John.
Comment 10 John M O'Donnell 2001-12-19 16:52:35 EST
I found item 17 in the FAQ addresses this issue.  So I followed it's directions
step by step, and it now works.  urw-aliases, with a modified config file
is the key to success.  How about making the RH 7.2 install do this.  (not
needed for RH 7.1).  I have yet to meet in a person anybody who had this working
from a vanillar RH 7.2 install.

John.
Comment 11 Andrew Moran 2002-01-03 17:28:00 EST
We have this exact same problem with Dia and a default RedHat 7.2 install. 
John's suggestion (follow item 17 in Dia's FAQ) worked, but it requires
installing a third party font package.   It seems weird that others aren't able
to reproduce this problem.   The URL for Dia's FAQ is:
http://www.lysator.liu.se/~alla/dia/faq.html#FontSupport
Comment 12 Alexander Larsson 2002-01-07 11:18:54 EST
It's strange that it seems to work for me.

I wonder why the adobe font didn't work while the urw one did.

I can't add urw-aliases to the distro though, since that would change which
fonts apps would get. I'd like to know what was different between them though.

We will have some rearrangement of the fonts in the next version i think. I'll
take a closer look at this then.
Comment 13 Tammy Fox 2002-03-10 16:41:33 EST
I have the same problem with Dia on RHL 7.2. It seems that the font path setup 
for an everything install causes this to happen. On a different box with
a custom install without all the packages, Dia can use different fonts.
Comment 14 Alexander Larsson 2002-03-11 11:05:28 EST
Hmmm. I have a bad feeling about this. Tammy, do you have Abiword installed on
the machine where it doesn't work?
Comment 15 Tammy Fox 2002-03-11 15:00:59 EST
Yes, abiword is installed. I tried rpm -e abiword and then killall -USR1 xfs to
reread the font server config file, but it still does the same thing. Feel
feel to come look at my box. I have 2 systems that are behaving this way.
Comment 16 Henrik Nilsson 2002-09-18 17:53:49 EDT
After upgrading to RH7.3 (actually, a fresh, custom install, which I then
brought up to date using up2date), I got a similar problem: Dia couldn't find
ANY font (besides courier), it seemed.

Following the FAQ helped.

By comparing /etc/X11/fs/config with versions from other machines running RH7.2,
I realized that two entries were conspicuously absent from the "catalogue"
variable:

    /usr/X11R6/lib/X11/fonts/75dpi
    /usr/X11R6/lib/X11/fonts/100dpi

(The ":unscaled" versions of these entries are there.)

Adding these entries to /etc/X11/fs/config, after undoing the changes suggested
by the FAQ, also seemed to resolve the problem.

I don't know anything about fontserver configuration, but it seems as if the
above two enries should be there, and thus that something went wrong during
the installation (I certainly had not touched the config file prior to trying
to fix the problem with Dia). Maybe I chose an odd collection of font RPMs
to install?

For reference, here are my font packages:

thoth-1% rpm -qa | grep -i font
XFree86-truetype-fonts-4.2.0-8
chkfontpath-1.9.5-2
XFree86-75dpi-fonts-4.2.0-8
urw-fonts-2.0-17
XFree86-base-fonts-4.2.0-8
XFree86-ISO8859-15-100dpi-fonts-4.2.0-8
ghostscript-fonts-5.50-3
XFree86-font-utils-4.2.0-8
ttfonts-ja-1.2-8
XFree86-ISO8859-15-75dpi-fonts-4.2.0-8
ttfonts-1.0-9
XFree86-100dpi-fonts-4.2.0-8
tetex-fonts-1.0.7-47
XFree86-cyrillic-fonts-4.2.0-8

/Henrik
Comment 17 Alexander Larsson 2003-08-12 08:10:23 EDT
rawhide now has dia 0.91, which uses gtk2. It handles fonts quite differently,
so this problem should be gone.
Comment 18 Alexander Larsson 2003-08-12 08:18:24 EDT
*** Bug 76851 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.