Bug 565872 - vnc does not work with F13 Alpha TC2
vnc does not work with F13 Alpha TC2
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Ales Kozumplik
Fedora Extras Quality Assurance
:
: 572123 (view as bug list)
Depends On:
Blocks: F13Blocker/F13FinalBlocker
  Show dependency treegraph
 
Reported: 2010-02-16 10:43 EST by Orion Poplawski
Modified: 2014-09-30 19:38 EDT (History)
4 users (show)

See Also:
Fixed In Version: anaconda-13.35-1.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-17 12:26:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda.log (9.17 KB, text/plain)
2010-02-17 12:03 EST, Orion Poplawski
no flags Details

  None (edit)
Description Orion Poplawski 2010-02-16 10:43:12 EST
Description of problem:

Doing pxe/ks install.  ks.cfg has:

install        
vnc

VNC server is started, but all install messages go to text screen on VT1.

Version-Release number of selected component (if applicable):
13.26
Comment 1 Ales Kozumplik 2010-02-17 05:30:43 EST
Hi Orion,

This is strange. I tried on TC2 from:
http://serverbeach1.fedoraproject.org/pub/alt/stage/13-Alpha.TC2/Fedora/i386/

Using pxe plus the exact kickstart you provided VNC starts fine for me and I can connect to it from the Gnome's Remote Desktop Viewer 2.28.1.

Did you notice the that the port has to be 1, so the address for the remote viewer looks like e.g. "10.34.39.30:1"?

Otherwise if the port number isn't the problem, can you please attach logfiles and describe what you see in the terminal? Is it the blue textual interface or just some log messages?

Thank you.
Ales
Comment 2 Orion Poplawski 2010-02-17 12:03:58 EST
Created attachment 394773 [details]
anaconda.log

Here's the anaconda log.  I see the normal blue text interface on VT1, VNC display is running and I can connect, but it is black.

I'm also using updates-565692.img to work around another anaconda bug so maybe that is causing trouble.
Comment 3 Ales Kozumplik 2010-02-22 07:54:00 EST
Hi Orion,

according to the log file, there is also a %pre section in your kickstart. Can you please the entire kickstart file?

Thanks,
Ales
Comment 4 Ales Kozumplik 2010-02-22 11:16:30 EST
Taking the needinfo back, I think I've found the root cause.
Comment 5 Ales Kozumplik 2010-03-05 04:45:11 EST
The fix for f13: 3781b3074893422638037fc90ed6e78345d1e2cc, should be released with anaconda-13.34.
Comment 6 Orion Poplawski 2010-03-17 12:26:25 EDT
Verified with 13.35 in Beta-TC0.
Comment 7 Ales Kozumplik 2010-03-18 04:01:39 EDT
*** Bug 572123 has been marked as a duplicate of this bug. ***
Comment 8 Fedora Update System 2010-03-18 13:22:33 EDT
anaconda-13.35-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/anaconda-13.35-1.fc13
Comment 9 Fedora Update System 2010-03-22 22:26:03 EDT
anaconda-13.35-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.