Bug 572123 - Anaconda 13-Alpha - no GUI
Anaconda 13-Alpha - no GUI
Status: CLOSED DUPLICATE of bug 565872
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Ales Kozumplik
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F13Blocker/F13FinalBlocker
  Show dependency treegraph
 
Reported: 2010-03-10 06:16 EST by Milan Kerslager
Modified: 2014-09-30 19:38 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-18 04:01:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
anaconda.log from Fedora 13 Alpha - failed GUI installer (5.52 KB, text/plain)
2010-03-10 06:16 EST, Milan Kerslager
no flags Details
Screenshot of tty3, in the middle of image are lines I originally reported (913.28 KB, image/png)
2010-03-11 07:00 EST, Milan Kerslager
no flags Details
Anaconda log (4.93 KB, text/plain)
2010-03-17 06:57 EDT, Milan Kerslager
no flags Details

  None (edit)
Description Milan Kerslager 2010-03-10 06:16:57 EST
Created attachment 399054 [details]
anaconda.log from Fedora 13 Alpha - failed GUI installer

I had no GUI when installation was booted. There is no /tmp/X.log. The messages I saw was:

Anaconda 13.32, the Fedora system installer - please wat.
Starting graphical installation.
Exception starting GUI installer: could not open display
GUI installer startup failed falling back to text mode.

I tryed network kickstart installation. Log from anaconda attached.
Comment 1 Chris Lumens 2010-03-10 09:25:18 EST
Can you attach /tmp/X.log as well?  Thanks.
Comment 2 Milan Kerslager 2010-03-10 14:11:11 EST
There were no such file /tmp/X.log
Comment 3 Chris Lumens 2010-03-10 16:03:51 EST
Can you please also check on tty3, tty4, and tty5 to see if there are any other messages indicating what might have happened?
Comment 4 Milan Kerslager 2010-03-11 07:00:48 EST
Created attachment 399325 [details]
Screenshot of tty3, in the middle of image are lines I originally reported

There are no traces of abnormal lines on other ttys. I just saw the error message on the first screen (blue, modesetted, with information about Anaconda version) as I wrote above when I initially reported this problem.
Comment 5 Chris Lumens 2010-03-11 10:12:36 EST
One more random guess here, and then I'm out of ideas.  Are you installing under vmware or some other virt environment?
Comment 6 Milan Kerslager 2010-03-11 10:19:22 EST
No, it's a generic PC in our lab.
Comment 7 Ales Kozumplik 2010-03-11 11:06:02 EST
Hi Milan,

It looks plausible that you are witnessing the same problem as bug 565872. You can either:
1) confirm this with the update image:
http://akozumpl.fedorapeople.org/565872_updates.img
2) Wait a couple of days and try with a later RC or Beta that includes anaconda-13.34.

Thanks.
Ales
Comment 8 Milan Kerslager 2010-03-17 04:12:49 EDT
13-Beta.TC0 has the problem still.
Comment 9 Milan Kerslager 2010-03-17 04:27:00 EDT
I have the problem even Anaconda is in version 13.35, co the patch in commnet #3 does not solve the problem.
Comment 10 Ales Kozumplik 2010-03-17 04:36:07 EDT
Hi,

can you please attach your kickstart and the anaconda.log you get with 13.35 to the bug?

Does graphical install start when you attempt an installation without a kickstart?

Thanks.
Ales
Comment 11 Milan Kerslager 2010-03-17 06:57:57 EDT
Created attachment 400713 [details]
Anaconda log

Please note - the installation fails for another bug (bug #567890).
Comment 12 Milan Kerslager 2010-03-17 07:43:28 EDT
My kisckstart file is here:

http://ftp.pslib.cz/pub/local/ks/pslib.php?rel=fb&arch=i386
Comment 13 Ales Kozumplik 2010-03-17 08:55:56 EDT
Hi Milan,

I think you must have used a wrong install.img as this line suggests:
12:03:17,938 INFO loader: URL_STAGE_MAIN: url is ftp://ftp.pslib.cz/pub/linux/fedora/linux/releases/test/13-Alpha/i386/images/install.img

I actually downloaded the install.img (thinking that only the pathname is wrong) but the anaconda inside it is not 13.35 (despite what the loader says at the top of the log..). Please try fixing your kickstart and let me know if the graphical install still fails.

Ales
Comment 14 Milan Kerslager 2010-03-17 15:28:47 EDT
No, the problem went away. Sorry for misreporting. The bug could be closed.
Comment 15 Ales Kozumplik 2010-03-18 04:01:39 EDT

*** This bug has been marked as a duplicate of bug 565872 ***

Note You need to log in before you can comment on or make changes to this bug.