Bug 56595 - up2date failed to complete kernel 2.4.9-12 upgrade
Summary: up2date failed to complete kernel 2.4.9-12 upgrade
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i686 Linux
low
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-11-21 16:33 UTC by Mark Harig
Modified: 2015-01-07 23:53 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-03 17:12:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mark Harig 2001-11-21 16:33:51 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

Description of problem:
This appears to be a duplicate of bug 54822.  I don't have a log of the 
output of 'up2date' (version 2.5.4) because I used the Red Hat Network 
icon to update my kernel (from 2.4.9-6 to 2.4.9-12).  I reported this 
problem to Red Hat Support (Service Request 194647), and after following 
several suggestions and requests for data, I updated the kernel "by hand" 
(editing /etc/lilo.conf, and running 'mkinitrd' and 'lilo').  The 
remaining problem is that 'up2date' does not recognize that the kernel has 
been updated (successful reboot, both with a boot diskette and without).  

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1. Click on the Red Hat Network icon to start the Red Hat Network Agent.
2. Click on 'Next' button and wait for 'Update agent progress' to complete.
	

Actual Results:  When the 'Packages Flagged to be Skipped' dialog is 
displayed, it erroneously includes the package name 'kernel', version 
2.4.9, release 12.


Expected Results:  This package should not be listed because it has 
already been installed.  Instead, up2date should report that there are no 
packages to update.

Additional info:

Comment 1 Adrian Likins 2001-12-03 17:11:59 UTC
This should be fixed in the next version of the client. 

(updated kernels still being listed as needing update)


Note You need to log in before you can comment on or make changes to this bug.