Bug 566186 - telnet/cmdline install doesn't shutdown after step complete
telnet/cmdline install doesn't shutdown after step complete
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F13Blocker/F13FinalBlocker 566259
  Show dependency treegraph
 
Reported: 2010-02-17 10:12 EST by James Laska
Modified: 2013-09-02 02:44 EDT (History)
7 users (show)

See Also:
Fixed In Version: anaconda-13.28-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 566259 588964 (view as bug list)
Environment:
Last Closed: 2010-05-05 09:22:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
/tmp/anaconda.log (28.58 KB, text/plain)
2010-02-17 10:12 EST, James Laska
no flags Details

  None (edit)
Description James Laska 2010-02-17 10:12:34 EST
Created attachment 394741 [details]
/tmp/anaconda.log

Description of problem:

A telnet install runs to completion, but a traceback occurs after clicking "Reboot" at the congratulations screen (see attached anaconda.log).

Version-Release number of selected component (if applicable):
 * anaconda-13.26 (plus http://jlaska.fedorapeople.org/updates-f13-alpha-tc2.img)

How reproducible:
 * 2 out of 2

Steps to Reproduce:
 * Following instructions at https://fedoraproject.org/wiki/QA:Testcase_Anaconda_User_Interface_Telnet
  
Actual results:

/tmp/anaconda.log shows ...

10:09:31,311 INFO anaconda: leaving (1) step complete
10:09:31,420 CRITICAL anaconda: anaconda 13.26 exception report
Traceback (most recent call first):
  File "/tmp/updates/anaconda", line 1206, in <module>
    del anaconda.intf
AttributeError: can't delete attribute


Expected results:

After clicking "Reboot", the system should reboot cleanly.
Comment 1 James Laska 2010-02-17 10:27:05 EST
This is probably not important, but just FYI ...

Since shutdown/reboot has failed, If I forcibly terminate my hung telnet client, then on the console that shows "waiting for telnet connection" I see the following message.

                ┌─────────────────┤ Telnet ├──────────────────┐
                │                                             │
                │ Running anaconda via telnet.                │
                │                                             │
                └─────────────────────────────────────────────┘

Loader exited unexpectedly!  Backtrace:                                        
/sbin/loader[0x408ed3]
/lib64/libc.so.6(exit+0xe2)[0x7fbd6231bdc2]
/sbin/loader[0x420431]
/sbin/loader[0x4204a1]
/sbin/loader[0x40b9f7]
/lib64/libc.so.6(__libc_start_main+0xfd)[0x7fbd62303d2d]
/sbin/loader[0x406e89]
install exited abnormally [1/1] 
The system will be rebooted when you press Ctrl-C or Ctrl-Alt-Delete.
Comment 2 Chris Lumens 2010-02-17 11:29:58 EST
0x408ed3 - /usr/src/debug/anaconda-13.26/loader/loader.c:1706
0x420431 - /usr/src/debug/anaconda-13.26/loader/telnetd.c:204
0x4204a1 - /usr/src/debug/anaconda-13.26/loader/telnetd.c:251
0x40b9f7 - /usr/src/debug/anaconda-13.26/loader/loader.c:2116
0x406e89 - ??:0
Comment 4 James Laska 2010-04-27 20:45:37 EDT
Still a problem using anaconda-13.38-1.  Does this need to be pulled into f13-branch?

Welcome to Fedora for i386




                ┌─────────────────┤ Telnet ├──────────────────┐
                │                                             │
                │ Running anaconda via telnet.                │
                │                                             │
                └─────────────────────────────────────────────┘



Loader exited unexpectedly!  Backtrace:                                        
/sbin/loader[0x804f18e]
/sbin/loader[0x804f244]
/lib/libc.so.6(exit+0xdf)[0xf7e60f]
/sbin/loader[0x8068796]
/sbin/loader[0x8068809]
/sbin/loader[0x80509b8]
/lib/libc.so.6(__libc_start_main+0xe6)[0xf65cc6]
/sbin/loader[0x804cee1]
install exited abnormally [1/1] 
The system will be rebooted when you press Ctrl-C or Ctrl-Alt-Delete.
Comment 5 Adam Williamson 2010-05-03 10:39:02 EDT
As far as I can see, this code is in the F13 branch and has been since 17th Feb:

http://git.fedoraproject.org/git/?p=anaconda.git;a=history;f=anaconda;h=0f54d65452a8bc0689c60bd44a51a7f4d8f0c426;hb=refs/heads/f13-branch

so it ought to be fixed on the version James tested. Assuming therefore that the fix is incorrect/incomplete and setting back to assigned...we obviously need a fix for this _really really fast_.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 6 Chris Lumens 2010-05-03 13:47:39 EDT
Looks like a completely and totally different bug to me.  Different bug reports for different problems, people.
Comment 7 Adam Williamson 2010-05-04 18:35:42 EDT
Er. The description of the original bug is:

"A telnet install runs to completion, but a traceback occurs after clicking
"Reboot" at the congratulations screen (see attached anaconda.log)."

the latest comment shows...a traceback occurring in a telnet install after clicking 'Reboot' at the congratulations screen...seems rather similar?
Comment 8 Jesse Keating 2010-05-04 19:48:29 EDT
Backtrace is different.  Cloning as a new bug.
Comment 9 Adam Williamson 2010-05-05 09:22:38 EDT
so we should close this one, then.

Note You need to log in before you can comment on or make changes to this bug.