Bug 588964 - telnet/cmdline install doesn't shutdown after step complete
Summary: telnet/cmdline install doesn't shutdown after step complete
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 13
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: F13Blocker, F13FinalBlocker 566259
TreeView+ depends on / blocked
 
Reported: 2010-05-04 23:49 UTC by Jesse Keating
Modified: 2013-01-10 05:56 UTC (History)
7 users (show)

Fixed In Version: anaconda-13.41-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 566186
Environment:
Last Closed: 2010-05-11 00:06:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jesse Keating 2010-05-04 23:49:46 UTC
+++ This bug was initially created as a clone of Bug #566186 +++

--- Additional comment from jlaska@redhat.com on 2010-04-27 20:45:37 EDT ---

Still a problem using anaconda-13.38-1.  Does this need to be pulled into f13-branch?

Welcome to Fedora for i386




                ┌─────────────────┤ Telnet ├──────────────────┐
                │                                             │
                │ Running anaconda via telnet.                │
                │                                             │
                └─────────────────────────────────────────────┘



Loader exited unexpectedly!  Backtrace:                                        
/sbin/loader[0x804f18e]
/sbin/loader[0x804f244]
/lib/libc.so.6(exit+0xdf)[0xf7e60f]
/sbin/loader[0x8068796]
/sbin/loader[0x8068809]
/sbin/loader[0x80509b8]
/lib/libc.so.6(__libc_start_main+0xe6)[0xf65cc6]
/sbin/loader[0x804cee1]
install exited abnormally [1/1] 
The system will be rebooted when you press Ctrl-C or Ctrl-Alt-Delete.

--- Additional comment from awilliam@redhat.com on 2010-05-03 10:39:02 EDT ---

As far as I can see, this code is in the F13 branch and has been since 17th Feb:

http://git.fedoraproject.org/git/?p=anaconda.git;a=history;f=anaconda;h=0f54d65452a8bc0689c60bd44a51a7f4d8f0c426;hb=refs/heads/f13-branch

so it ought to be fixed on the version James tested. Assuming therefore that the fix is incorrect/incomplete and setting back to assigned...we obviously need a fix for this _really really fast_.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

--- Additional comment from clumens@redhat.com on 2010-05-03 13:47:39 EDT ---

Looks like a completely and totally different bug to me.  Different bug reports for different problems, people.

--- Additional comment from awilliam@redhat.com on 2010-05-04 18:35:42 EDT ---

Er. The description of the original bug is:

"A telnet install runs to completion, but a traceback occurs after clicking
"Reboot" at the congratulations screen (see attached anaconda.log)."

the latest comment shows...a traceback occurring in a telnet install after clicking 'Reboot' at the congratulations screen...seems rather similar?

--- Additional comment from jkeating@redhat.com on 2010-05-04 19:48:29 EDT ---

Backtrace is different.  Cloning as a new bug.

Comment 1 Chris Lumens 2010-05-05 14:26:48 UTC
0x804f18e - /usr/src/debug/anaconda-13.38/loader/loader.c:1721
0x804f244 - /usr/src/debug/anaconda-13.38/loader/loader.c:1731
<libc>
0x8068796 - /usr/src/debug/anaconda-13.38/loader/telnetd.c:204
0x8068809 - /usr/src/debug/anaconda-13.38/loader/telnetd.c:251
0x80509b8 - /usr/src/debug/anaconda-13.38/loader/loader.c:2124

Comment 2 Fedora Update System 2010-05-07 07:42:48 UTC
anaconda-13.41-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/anaconda-13.41-1.fc13

Comment 3 James Laska 2010-05-07 16:09:13 UTC
Confirmed fixed in anaconda-13.41-1 (F-13-RC1-i386).

Welcome to Fedora for i386

                ┌─────────────────┤ Telnet ├──────────────────┐
                │                                             │
                │ Running anaconda via telnet.                │
                │                                             │
                └─────────────────────────────────────────────┘

disabling swap...                                                              
	/dev/dm-1
unmounting filesystems...
	/mnt/runtime done
	disabling /dev/loop0 LOOP_CLR_FD failed: 16
	/proc done
	/dev/pts done
	/sys done
	/selinux done
	/mnt/sysimage/boot done
	/mnt/sysimage/dev/pts done
	/mnt/sysimage/dev/shm done
	/mnt/sysimage/dev done
	/mnt/sysimage/proc/bus/usb done
	/mnt/sysimage/proc done
	/mnt/sysimage/sys done
	/mnt/sysimage/selinux done
	/mnt/sysimage done
waiting for mdraid sets to become clean...
sending termination signals...done
sending kill signals...done
rebooting system
Restarting system.

Guest installation complete... restarting guest.


Note You need to log in before you can comment on or make changes to this bug.