Bug 56622 - KDM. How to configure kdmrc to make the XDMCP protocol work?
KDM. How to configure kdmrc to make the XDMCP protocol work?
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-22 04:57 EST by Need Real Name
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-07 17:02:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-11-22 04:57:37 EST
Description of Problem:

I want to turn my RedHat 7.2 machine as a XTerminal and XServer via the
XDMCP protocol.
I worked well until RedHat 7.1
I thought first it was a problem with X11 (See my bug report #55826, copy
of the modifications I did on some files stored under /etc/X11/xdm) but
then I realized it comes from kdm
(I simply tried my modifications with xdm instead of kdm and it works)
I saw that there is now a file called /etc/kde/kdm/kdmrc
I tried to play with it but without success.

Can someone tell me simply what to do.

Version-Release number of selected component (if applicable):
kdebase-2.2-12


How Reproducible:

Easily, just modify the files accorded to the description of bug #55826 and
see by yourself...
You can replace in /etc/inittab
/etc/X11/prefdm by /usr/X11r6/bin/xdm and then it works

Steps to Reproduce:
1.  Modify Xservers, inittab, Xresources, xdm-config, Xaccess
2.  Try to make the XDMCP protocol available via /etc/kde/kdm/kdmrc

Here is what I tried

[root@brest kdm]# diff kdmrc kdmrc.org 
61c61
< #DaemonMode=false
---
> DaemonMode=false
87c87
< #Enable=false
---
> Enable=false
89c89
< Port=177
---
> #Port=177


3. as root, restart the XServer.
init 3
init 5 

Actual Results:

A grey screen....

Expected Results:

A menu with a list of machine I can log on.
Comment 1 Ngo Than 2004-10-07 17:02:25 EDT
it works for me. it looks like a configuration problem

Note You need to log in before you can comment on or make changes to this bug.