Bug 56624 - automake 1.5 fails to build dependency files for Glide3
automake 1.5 fails to build dependency files for Glide3
Status: CLOSED CURRENTRELEASE
Product: Red Hat Raw Hide
Classification: Retired
Component: automake15 (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Reed
Brian Brock
:
: 58207 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-22 06:30 EST by Bernhard Rosenkraenzer
Modified: 2007-04-18 12:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-19 01:52:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bernhard Rosenkraenzer 2001-11-22 06:30:16 EST
Description of Problem:
Trying to build XFree86 with the current automake leads to error messages 
while building the Glide3 library even after fixing configure.in and 
friends.

This happens:
make[2]: Entering directory `/usr/src/CVS/Glide3/swlibs/fxmisc'
makefile.autoconf:168: .deps/fx64.Plo: No such file or directory
makefile.autoconf:169: .deps/fximg.Plo: No such file or directory
makefile.autoconf:170: .deps/fxos.Plo: No such file or directory
makefile.autoconf:171: .deps/linutil.Plo: No such file or directory
because the following code has been generated:
include $(DEPDIR)/fx64.Plo
include $(DEPDIR)/fximg.Plo
include $(DEPDIR)/fxos.Plo
include $(DEPDIR)/linutil.Plo
from this automake file:
include_HEADERS         = 3dfx.h linutil.h
noinst_HEADERS          = fx64.h fxdll.h fximg.h fxglob.h \
                          fxos.h fxver.h glob.h
noinst_LTLIBRARIES      = libfxmisc.la
libfxmisc_la_SOURCES    = fx64.c fximg.c fxos.c linutil.c

(and the depfiles haven't been generated).

Trying to invoke depcomp manually (not sure if I figured out the correct 
parameters):
source=swlibs/fxmisc/fx64.c object=swlibs/fxmisc/fx64.lo depmode=gcc3 
./depcomp gcc -c swlibs/fxmisc/fx64.c -o swlibs/fxmisc/fx64.lo 
-Iswlibs/fxmisc swlibs/fxmisc/.deps/fx64.TPlo: No such file or directory

Version-Release number of selected component (if applicable):
automake-1.5-1
autoconf-2.52-4

How Reproducible:
100%

Steps to Reproduce:
1. Install the XFree86 source RPM, rpm -bp XFree86.spec
2. cd to the Glide3 subdir, fix up configure.in to do AM_PROG_AS
3. aclocal;automake -a;autoconf;./configure; make -f makefile.autoconf
Comment 1 Tom Tromey 2001-11-28 21:20:49 EST
I believe this is a real, but obscure, automake bug.
I notice that the make invocation is "make -f makefile.autoconf"
The code that generates the initial dependency files contains this:
  case $mf in
  Makefile) dirpart=.;;
  */Makefile) dirpart=`AS_DIRNAME("$mf")`;;
  *) continue;;
  esac
Oops -- it skips your case.
I'm not entirely sure what the automake fix ought to be,
but I'll ask the other developers about it.
It probably isn't important to enable dependency tracking when
building an RPM, since you'll probably just build it once and
discard the build tree.
I think disabling this in Makefile.am ought to work.
Disabling it via the configure command line might work but
I'm not certain.

I've filed an automake bug report.
I don't know when or whether it will be fixed.

Comment 2 Tom Tromey 2001-12-29 21:41:44 EST
FYI, I've checked in a fix for this to the automake CVS trunk.
Comment 3 Jens Petersen 2002-01-09 01:03:09 EST
Thanks. I added the fix to automake-1.5-2.
Comment 4 Jens Petersen 2002-01-11 04:27:03 EST
The fix seemed to break things, so for the time being it has been backed out.
Comment 5 Jens Petersen 2002-01-18 02:43:26 EST
*** Bug 58207 has been marked as a duplicate of this bug. ***
Comment 6 Mike A. Harris 2002-01-25 04:31:10 EST
Glide 3 builds in rawhide now.  We're using automake 1.4 however.
It is hard coded in the specfile.  So if you fix this please
let me know so we can try using a newer automake.
Comment 7 Jens Petersen 2002-03-27 01:26:29 EST
moved to automake15 component
Comment 8 Jens Petersen 2002-07-09 04:33:38 EDT
The problem still seems to persist in automake-1.6.2.
Comment 9 Daniel Reed 2004-08-19 01:18:42 EDT
Glide3 appears to build using rawhide automake; can I close this?
Comment 10 Mike A. Harris 2004-08-19 01:52:36 EDT
Closing as "CURRENTRELEASE" (Fedora Core 2).

Note You need to log in before you can comment on or make changes to this bug.