Bug 58207 - depout-mf patch breaks several builds
Summary: depout-mf patch breaks several builds
Status: CLOSED DUPLICATE of bug 56624
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: automake (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jens Petersen
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-01-11 00:35 UTC by Enrico Scholz
Modified: 2007-04-18 16:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-11 00:35:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Enrico Scholz 2002-01-11 00:35:31 UTC
Description of Problem:

The depout-mf.patch (introduced in 1.5-2) uses the statement

| dirpart=`AS_DIRNAME("$mf")`

I don't know exactly why, but this breaks some builds. Minimal example is

----
$ cat >configure.ac <'EOF'
AC_INIT(X,1,X)
AM_INIT_AUTOMAKE(X,1)
AM_OUTPUT_DEPENDENCY_COMMANDS
AC_OUTPUT()
EOF

$ autoreconf 
autoreconf: `aclocal.m4' is created
configure:1988: error: possibly undefined macro: AS_DIRNAME
autoreconf: autoconf failed with exit status: 1
 at /usr/bin/autoreconf line 356
----

Perhaps it's an autoconf issue, but because previous automake versions (without
this patch) worked fine, I am entering it here...


Version-Release number of selected component (if applicable):

automake-1.5-2
autoconf-2.52-5

Comment 1 Jens Petersen 2002-01-18 07:43:31 UTC
The patch was backed out in 1.5-4.

*** This bug has been marked as a duplicate of 56624 ***


Note You need to log in before you can comment on or make changes to this bug.