Bug 566633 - [abrt] crash in gdb-7.0.1-31.fc12
Summary: [abrt] crash in gdb-7.0.1-31.fc12
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: gdb
Version: 12
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jan Kratochvil
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:6a16ed9b9038d007b683e355a1e...
: 587849 (view as bug list)
Depends On:
Blocks: 565352
TreeView+ depends on / blocked
 
Reported: 2010-02-19 01:50 UTC by Erik Berg
Modified: 2010-06-02 10:04 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 565352
Environment:
Last Closed: 2010-06-02 10:04:50 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (12.28 KB, text/plain)
2010-02-19 01:50 UTC, Erik Berg
no flags Details
Eclipse debugging screenshot (48.51 KB, image/png)
2010-06-02 10:03 UTC, Jan Kratochvil
no flags Details

Description Erik Berg 2010-02-19 01:50:39 UTC
abrt 1.0.6 detected a crash.

architecture: i686
Attached file: backtrace
cmdline: /usr/bin/gdb -i mi --tty=/tmp/qt_temp.kn4775
comment: expanded a variable in qt-creator
component: gdb
executable: /usr/bin/gdb
kernel: 2.6.31.12-174.2.19.fc12.i686.PAE
package: gdb-7.0.1-31.fc12
rating: 4
reason: Process was terminated by signal 6 (Aborted)
release: Fedora release 12 (Constantine)

How to reproduce
-----
1. struct some_data { int a, b, c } mydata[400]; //haven't really tested with this struct.
2. compile, expand the mydata variable, and it's children.
3. crash?

Comment 1 Erik Berg 2010-02-19 01:50:42 UTC
Created attachment 395024 [details]
File: backtrace

Comment 2 Karel Klíč 2010-05-25 09:12:06 UTC
*** Bug 587849 has been marked as a duplicate of this bug. ***

Comment 3 Jan Kratochvil 2010-06-02 10:03:26 UTC
Created attachment 418972 [details]
Eclipse debugging screenshot

Comment 4 Jan Kratochvil 2010-06-02 10:04:50 UTC
As the Bug 587849 reproduces the same problem using Eclipse-CDT and I was unable to build a project in qt-creator tried to reproduce it in Eclipse-CDT but it works for me in the Comment 3.  Unable to debug it without reproducer just according to the backtrace.


Note You need to log in before you can comment on or make changes to this bug.