Bug 56675 - Inspiron 8100 w/Geforce2 Go does not work in RH7.2
Inspiron 8100 w/Geforce2 Go does not work in RH7.2
Status: CLOSED DUPLICATE of bug 41157
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.2
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-23 23:30 EST by Art Fore
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-24 10:32:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Art Fore 2001-11-23 23:30:28 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0; DigExt)

Description of problem:
After installin RH 7.2, all I get in mode 5 is vertical colored bars on 
the screen. Installed latest NVIDIA drivers per messaage 7259 on Yahoo 
linux-dell-laptops user forum which had a few errors. This worked until I 
installed OpenOffice 638C. This crashed the KDE Control Panel. Reinstalled 
everything using Gnome Control Panel. Same thing. In both cases, 
segmentation fault error.

Upgraded Kernel to 2.4.9-13. Things when from bad to worse. Tried to 
reinstall drivers, said they were already installed. Done an upgrade, same 
thing, will not go to mode 5, only mode 3.

Go back to 2.4.7-10 kernel, now Nautilus crashes with segmentation error.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.reinstall and start over.
2.Try to login in graphics mode.
3.
	

Actual Results:  same thing

Expected Results:  It should work

Additional info:

Computer is Dell Inspiron 8100 with NVIDIA Geforce2 Go video, 512 meg ram, 
30 Gig harddrive, DVD-CDR, floppy, USB Maxtor 40 Gig portable hardrive, 
PS2 mouse. USB has no effect, occurs with or without, occurs with PS2 
mouse or USB mouse. Display is UltraXVGA 15" 1600X1200 resolution

There is a company that sells an Inspiron 8100 same as mine configured 
with RH Linux 7.2, So it can be done. Would like to know the secrets.
Comment 1 Mike A. Harris 2001-11-24 10:32:20 EST
This video hardware is not supported.  Also, usage of the Nvidia
binary only drivers is not supported.  Please contact Nvidia for
technical support for Geforce 2 Go.

Just to clarify this issue even more, right from the horses mouth:




Date: Sat, 20 Oct 2001 14:39:19 -0700 (PDT)
From: Mark Vojkovich <mvojkovich@nvidia.com>
To: XFree86 devel list <devel@xfree86.org>
Content-Type: TEXT/PLAIN; charset=US-ASCII
Subject: Re: Nvidia status document:
 
On Sat, 20 Oct 2001, Thomas Witzel wrote:
 
> What means GeForce2 Go is not supported ? XFree runs on mine...
>
Some people have said the Toshiba laptops work with the "nv" driver.
I've never seen it work, and frankly, I don't see how it can.  It
certainly doesn't work on the one we have here.  Must be some sort
of bios miracle you are seeing.  The "nv" driver definitely does not
support the GeForce2 Go in terms of having code required to make
it work for the general case.
 
                                Mark.

Comment 2 Mike A. Harris 2001-11-24 10:32:49 EST

*** This bug has been marked as a duplicate of 41157 ***
Comment 3 Art Fore 2001-11-24 12:44:14 EST
Why does RH Linux 7.2 come up with Geforce2 Go as a selection for the video 
driver then if it is not supported?

Art
Comment 4 Mike A. Harris 2001-11-24 14:02:14 EST
Simple.  In the interest of TRYING to support our users, we have made
our tools _aware_ of new hardware, so that they can detect it, and when
drivers are available, the new hardware will "just work" without having
to update Xconfigurator, kudzu, pciutils and 50 other utilities.

It is obvious to me now though that it is more of a problem to users than
a help.  I've been asked this question about 20 times now, and so in the
interest of preventing user confusion, I am going to now disable support
in our tools for all hardware that we do not directly ship support for.

Thanks for your feedback!
Comment 5 NILMONI DEB 2001-11-26 10:24:25 EST
It may be a good idea to detect the card anyway AND report that its unsupported. This way, the user will not be confused when later he/she finds that lspci can identify the video card but not Xconfigurator.
This will help the user and developer a lot because the user:

1. will atleast know what video card (with exact device id) he/she has
2. will try for a non-redhat/non-xfree86 solution (such as closed source nvidia and savage drivers)
3. will not make unnecessary bugzilla reports

thanks
- Nil

Note You need to log in before you can comment on or make changes to this bug.