Bug 41157 - UXGA Display/NVIDIA GeForce 2 Go video not supported
UXGA Display/NVIDIA GeForce 2 Go video not supported
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.1
i686 Linux
high Severity high
: ---
: ---
Assigned To: Mike A. Harris
Brock Organ
:
: 56675 59461 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-17 17:54 EDT by Need Real Name
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-02 16:21:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-05-17 17:54:56 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.0; Windows 98; DigExt)

Description of problem:
In the installer, 800x600 test page is the highest resolution to work with 
any of the NVIDIA/custom options. When booting RHL7.1 after install, X 
displays garbage screen. 

How reproducible:
Always

Steps to Reproduce:
1.Insert RHL7.1 Install CD #1
2.Turn on computer
3.Follow install instructions
4.Boot linux
	

Actual Results:  Initial boot sequence okay.
Tries to load X:
Garbage screen - blue + white squares. 

Expected Results:  Viewable X: KDE

Additional info:

I have a Dell Inspiron 8000 with 15" UXGA display and an NVIDIA GeForce 2 
Go with 32MB DDR.
Comment 1 Brent Fox 2001-05-18 15:31:49 EDT
So does the graphical installer work?  Is the problem just after rebooting?  

Also, after the installation, can you run Xconfigurator and see if that solves
to problem?  However, before you run Xconfigurator, please make a backup of the
/etc/X11/XF86Config and /etc/X11/XF86Config-4 files so that if running
Xconfigurator fixes the problem, we can look at the config files that anaconda
wrote and see what's wrong with them.
Comment 2 Need Real Name 2001-05-18 21:20:49 EDT
The graphical installer works fine, except for the test screen, which only worked in 800x600 mode, so I set the resolution for that. X hangs the computer if 
you try to load it. I tried Xconfigurator, to no avail. I also downloaded two very recent RPMs from the NVIDIA website (which were hard to find as they're 
not in the linux drivers page). After installing, the NVKernel fails altogether. I'm not at my laptop at present, otherwise I would provide a log file. Others 
have had similar problems - see the delltalk website. Dell Canada were extremely unhelpful as they 'only support the OS supplied with the system'. You 
also can't get linux pre-installed in Canada. Thanks for your help.

Dan
Comment 3 Brent Fox 2001-05-21 13:39:50 EDT
Mike, are the nVidia drivers the closed source?  Do we have a shot at fixing
this problem?
Comment 4 Brent Fox 2001-06-12 23:42:45 EDT
Mike, any input?
Comment 5 Trond Eivind Glomsrxd 2001-07-02 11:02:27 EDT
The nVidia drivers downloaded from nVidia are closed source, the ones included
with XFree86 aren't.
Comment 6 Peter L. Thomas 2001-07-02 16:21:32 EDT
While they may be "closed source," I had (nearly) the same problem and was
successful in building and installing the NVIDIA Kernel and GLX drivers from
NVIDIA's web-site.

The trick is to ignore the desire to use their supposed src.rpm and just build
the drivers from their "generic UNIX tarball."  I know it hurts--but it does
work.

Long-term:  guess we'll have to roll our our RPM/SRPM to get this to behave.
Comment 7 Mike A. Harris 2001-10-20 13:20:37 EDT
The GeForce 2 Go is not supported.  XFree86 4.2.0 aparently when released
will support this card in 2D.  For now, the only way to get support is
to use Nvidia's binary drivers.  I do know that a while back, the binary
drivers were broken, but if I recall correctly, the latest ones work.
Comment 8 Mike A. Harris 2001-10-20 19:07:15 EDT
Additional datapoint

Date: Sat, 20 Oct 2001 14:39:19 -0700 (PDT)
From: Mark Vojkovich <mvojkovich@nvidia.com>
To: XFree86 devel list <devel@xfree86.org>
Content-Type: TEXT/PLAIN; charset=US-ASCII
Subject: Re: Nvidia status document:
 
On Sat, 20 Oct 2001, Thomas Witzel wrote:
 
> What means GeForce2 Go is not supported ? XFree runs on mine...
>
 
   Some people have said the Toshiba laptops work with the "nv" driver.
I've never seen it work, and frankly, I don't see how it can.  It
certainly doesn't work on the one we have here.  Must be some sort
of bios miracle you are seeing.  The "nv" driver definitely does not
support the GeForce2 Go in terms of having code required to make
it work for the general case.
 
                                Mark.
Comment 9 Mike A. Harris 2001-11-24 10:32:43 EST
*** Bug 56675 has been marked as a duplicate of this bug. ***
Comment 10 Mike A. Harris 2002-02-08 18:12:56 EST
*** Bug 59461 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.