Bug 566979 - Failed dependencies and login problem; basic video driver installation, F13 Alpha RC1.
Summary: Failed dependencies and login problem; basic video driver installation, F13 A...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: pungi
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: David Cantrell
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F13Alpha, F13AlphaBlocker
TreeView+ depends on / blocked
 
Reported: 2010-02-20 21:38 UTC by Richard Ryniker
Modified: 2013-01-10 05:43 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-02-23 02:22:52 UTC


Attachments (Terms of Use)
/var/log/secure shows failures in root login. (1017 bytes, application/octet-stream)
2010-02-20 21:38 UTC, Richard Ryniker
no flags Details
anaconda.log (41.12 KB, text/plain)
2010-02-21 17:20 UTC, Richard Ryniker
no flags Details
anaconda.program.log (87.43 KB, application/octet-stream)
2010-02-21 17:20 UTC, Richard Ryniker
no flags Details
anaconda.storage.log (244.34 KB, text/plain)
2010-02-21 17:21 UTC, Richard Ryniker
no flags Details
anaconda.syslog (59.79 KB, text/plain)
2010-02-21 17:21 UTC, Richard Ryniker
no flags Details
anaconda.xlog (59.65 KB, text/plain)
2010-02-21 17:22 UTC, Richard Ryniker
no flags Details
anaconda.yum.log (22.92 KB, text/plain)
2010-02-21 17:22 UTC, Richard Ryniker
no flags Details

Description Richard Ryniker 2010-02-20 21:38:48 UTC
Created attachment 395292 [details]
/var/log/secure  shows failures in root login.

Description of problem:
After bug 566948 stymied graphical install, tried installation with 
basic video driver.  This generated complaints about missing dependencies for:
 initscripts
 openssh-server
 coreutils
 policycoreutils
 pam
 lvm2
 dracut
 udev
 ncurses-libs
 ncurses-base

Chose to continue installation.  179 packages installed.
After installation completed, and subsequent reboot, could not login
as root.  Rebooted to runlevel 1 successfully, and found in /var/syslog/messages:

Feb 20 13:57:18 localhost init: tty (/dev/tty1) main process ended, respawning
Feb 20 13:57:57 localhost init: tty (/dev/tty1) main process ended, respawning

Version-Release number of selected component (if applicable):
13.26

How reproducible:
Always

Steps to Reproduce:
1. Boot from alpha-RC1 DVD
2. Select "install with basic video driver"
3.
  
Actual results:
Dependency failure messages during installation; unable to login
as root.

Expected results:
Correct packages on install media.
Successful login as root.

Additional info:
The following files are available:
 anaconda.syslog
 anaconda.xlog
 anaconda.storage.log
 anaconda.program.log
 anaconda.log
but they say nothing about failed dependencies.

Comment 1 He Rui 2010-02-21 06:00:35 UTC
I encountered the same problem with anaconda 13.28 and it was 100% reproducible.

The images I tested are at:
http://alt.fedoraproject.org/pub/alt/stage/13-Alpha.RC1/Fedora/

Comment 2 He Rui 2010-02-21 09:22:57 UTC
Set it as F13 alpha blocker bug according to Alpha Release Requirements: 2. No file conflicts or unresolved package dependencies during a media-based (CD/DVD) install  and (for root login issue) maybe 12. In most cases, the installed system must boot to a functional (graphical) environment.

Comment 3 Chris Lumens 2010-02-21 16:33:31 UTC
Please attach all the anaconda log files to this bug so we can see what's going on.  Thanks.

Comment 4 Richard Ryniker 2010-02-21 17:20:10 UTC
Created attachment 395361 [details]
anaconda.log

Comment 5 Richard Ryniker 2010-02-21 17:20:49 UTC
Created attachment 395362 [details]
anaconda.program.log

Comment 6 Richard Ryniker 2010-02-21 17:21:17 UTC
Created attachment 395364 [details]
anaconda.storage.log

Comment 7 Richard Ryniker 2010-02-21 17:21:40 UTC
Created attachment 395365 [details]
anaconda.syslog

Comment 8 Richard Ryniker 2010-02-21 17:22:05 UTC
Created attachment 395366 [details]
anaconda.xlog

Comment 9 Richard Ryniker 2010-02-21 17:22:55 UTC
Created attachment 395367 [details]
anaconda.yum.log

Comment 10 Chris Lumens 2010-02-22 14:35:31 UTC
Looks like the underlying problem is that system-config-firewall-base is not included in the install media, therefore we can't install it and run lokkit to configure the machine for logging in:

13:47:01,285 DEBUG anaconda: no package matching system-config-firewall-base
...
13:54:26,197 ERROR anaconda: Error running /usr/sbin/lokkit: No such file or directory

Comment 11 Jesse Keating 2010-02-23 02:16:53 UTC
this appears to be a problem with pungi during the compose.  Looking into it now.

Comment 12 Jesse Keating 2010-02-23 02:22:52 UTC
This could have been a yum problem, or just a problem with the state of the repos at the time, but I cannot duplicate it at this point.

Comment 13 He Rui 2010-02-23 11:33:30 UTC
Verified fixed in F13 alpha RC2.


Note You need to log in before you can comment on or make changes to this bug.