Bug 567371 - udev creates bad symbolic links
udev creates bad symbolic links
Status: CLOSED DUPLICATE of bug 566680
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-22 14:01 EST by john bray
Modified: 2010-03-05 16:19 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-05 16:19:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description john bray 2010-02-22 14:01:11 EST
Description of problem:udev creates symbolic links in /usr/bin to udevadm in ../sbin/udevadm  but udev adm is in /sbin, not /usr/sbin


Version-Release number of selected component (if applicable):
udev-145-15.fc12

How reproducible:
i presume on every install/upgrade.

Steps to Reproduce:
1. ls -l /usr/bin/udevinfo  or udevtest
2.
3.
  
Actual results:
lsl /usr/bin/udev*
lrwxrwxrwx. 1 root root 15 2010-02-13 02:44 /usr/bin/udevinfo -> ../sbin/udevadm
lrwxrwxrwx. 1 root root 15 2010-02-13 02:44 /usr/bin/udevtest -> ../sbin/udevadm


Expected results:
lsl /usr/bin/udev*
lrwxrwxrwx. 1 root root 15 2010-02-13 02:44 /usr/bin/udevinfo -> /sbin/udevadm
lrwxrwxrwx. 1 root root 15 2010-02-13 02:44 /usr/bin/udevtest -> /sbin/udevadm


Additional info:

note the additional symbolic links in /sbin, which are sort of silly, but not harmful:

lsl /sbin/udev*
lrwxrwxrwx. 1 root root   15 2010-02-13 02:44 /sbin/udevcontrol -> ../sbin/udevadm
lrwxrwxrwx. 1 root root   15 2010-02-13 02:44 /sbin/udevsettle -> ../sbin/udevadm
lrwxrwxrwx. 1 root root   15 2010-02-13 02:44 /sbin/udevtrigger -> ../sbin/udevadm
Comment 1 Charles R. Anderson 2010-03-05 16:19:35 EST

*** This bug has been marked as a duplicate of bug 566680 ***

Note You need to log in before you can comment on or make changes to this bug.