Bug 566680 - Broken symlinks in udev
Broken symlinks in udev
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
: 567371 574048 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-19 06:51 EST by kevin reichhart
Modified: 2010-03-25 18:36 EDT (History)
7 users (show)

See Also:
Fixed In Version: udev-145-19.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-25 17:57:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description kevin reichhart 2010-02-19 06:51:56 EST
symlinks for /usr/bin/udevinfo and /usr/bin/udevtest point to /usr/sbin/udevadm, but udevadm is installed in /sbin.

[ddckevinr@m4300-althea ~]$ rpm -qa udev
udev-145-15.fc12.x86_64
[ddckevinr@m4300-althea ~]$ rpm -ql udev|grep bin
/sbin/scsi_id
/sbin/start_udev
/sbin/udevadm
/sbin/udevcontrol
/sbin/udevd
/sbin/udevsettle
/sbin/udevtrigger
/usr/bin/udevinfo
/usr/bin/udevtest
/usr/sbin/udevmonitor
[ddckevinr@m4300-althea ~]$ ls -l /usr/bin/udev*
lrwxrwxrwx. 1 root root 15 2010-02-19 06:37 /usr/bin/udevinfo -> ../sbin/udevadm
lrwxrwxrwx. 1 root root 15 2010-02-19 06:37 /usr/bin/udevtest -> ../sbin/udevadm
[ddckevinr@m4300-althea ~]$
Comment 1 Charles R. Anderson 2010-03-05 16:19:35 EST
*** Bug 567371 has been marked as a duplicate of this bug. ***
Comment 2 Charles R. Anderson 2010-03-05 16:20:59 EST
Here are all the symlinks in the package:

>rpm -qlv udev | grep ^l
lrwxr-xr-x    1 root    root                       19 Jan 26 06:42 /sbin/scsi_id -> ../lib/udev/scsi_id
lrwxr-xr-x    1 root    root                       15 Jan 26 06:42 /sbin/udevcontrol -> ../sbin/udevadm
lrwxr-xr-x    1 root    root                       15 Jan 26 06:42 /sbin/udevsettle -> ../sbin/udevadm
lrwxr-xr-x    1 root    root                       15 Jan 26 06:42 /sbin/udevtrigger -> ../sbin/udevadm
lrwxr-xr-x    1 root    root                       15 Jan 26 06:42 /usr/bin/udevinfo -> ../sbin/udevadm
lrwxr-xr-x    1 root    root                       15 Jan 26 06:42 /usr/bin/udevtest -> ../sbin/udevadm
lrw-r--r--    1 root    root                       18 Jan 26 06:42 /usr/lib/ConsoleKit/run-seat.d/udev-acl.ck -> /lib/udev/udev-acl
lrwxr-xr-x    1 root    root                       15 Jan 26 06:42 /usr/sbin/udevmonitor -> ../sbin/udevadm

As you can see, /usr/bin/udevinfo, /usr/bin/udevtest, and /usr/sbin/udevmonitor are all broken/dangling symlinks.
Comment 3 Heldwin 2010-03-10 10:13:56 EST
Same thing for x86.

# rpm -q udev
udev-145-15.fc12.i686

# rpm -ql udev|grep bin
/sbin/scsi_id
/sbin/start_udev
/sbin/udevadm
/sbin/udevcontrol
/sbin/udevd
/sbin/udevsettle
/sbin/udevtrigger
/usr/bin/udevinfo
/usr/bin/udevtest
/usr/sbin/udevmonitor

# whereis udevinfo
udevinfo: /usr/bin/udevinfo

# /usr/bin/udevinfo
-bash: /usr/bin/udevinfo: Aucun fichier ou dossier de ce type
Comment 4 Harald Hoyer 2010-03-16 12:08:00 EDT
*** Bug 574048 has been marked as a duplicate of this bug. ***
Comment 5 Fedora Update System 2010-03-19 07:16:39 EDT
udev-145-16.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/udev-145-16.fc12
Comment 6 Fedora Update System 2010-03-23 19:39:39 EDT
udev-145-19.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update udev'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/udev-145-19.fc12
Comment 7 Fedora Update System 2010-03-25 18:35:07 EDT
udev-145-19.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.