Bug 56771 - %post scriptlet fails because of bad info-entries
Summary: %post scriptlet fails because of bad info-entries
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: fileutils   
(Show other bugs)
Version: 1.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-11-27 13:22 UTC by Enrico Scholz
Modified: 2007-04-18 16:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-29 15:34:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Enrico Scholz 2001-11-27 13:22:46 UTC
Description of Problem:

When updating fileutils-4.1.2-1 to fileutils-4.1.2-2 the %post scriptlet fails:

$ rpmU fileutils-4.1.2-2.i386.rpm
install-info: menu item `GNU Free Documentation License' already exists,
for file `(none)'
Fehler: execution of %post scriptlet from fileutils-4.1.2-2 failed, exit
status 1
-----

This is caused by missing filename-specifiers in the coreutils.info file:

$ zcat /usr/share/info/coreutils.info.gz | head    
This is coreutils.info, produced by makeinfo version 4.0b from
coreutils.texi.

START-INFO-DIR-ENTRY
* GNU Utilities: (coreutils).         GNU Utilities.
* Common options:                     Common options.
* File permissions:                   Access modes.
* Date input formats:                 Specifying date strings.
* Opening the software toolbox:       The software tools philosophy.
* GNU Free Documentation License:     The license for this documentation.
-----

There the "Common options:" ... "GNU Free Doc..." entries should have a 
'(coreutils).' after the colon.


Version-Release number of selected component (if applicable):

fileutils-4.1.2-2

Comment 1 Bernhard Rosenkraenzer 2001-11-27 14:57:22 UTC

*** This bug has been marked as a duplicate of 56759 ***

Comment 2 Enrico Scholz 2001-11-29 15:33:58 UTC
It's not a duplicate... 

#56759 was because of already existing info-files; this bug is because of
ill-formated info-entries.

(verified with fileutils-4.1.2-3 also)

Comment 3 Bernhard Rosenkraenzer 2001-12-03 15:14:25 UTC
Fixed in 4.1.3-1



Note You need to log in before you can comment on or make changes to this bug.