Bug 56784 - --lba32 option fails in kickstart
--lba32 option fails in kickstart
Status: CLOSED DUPLICATE of bug 53923
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-11-27 12:03 EST by Jeff L. Smith
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-11-27 12:04:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Jeff L. Smith 2001-11-27 12:03:57 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.7-10 i686)

Description of problem:

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Include the following line in a kickstart file:

bootloader --useLilo --linear --lba32 --location=mbr

2.Try installing using kickstart from the boot floppy

Actual Results:  Probing for mouse type:   Generic - 3 Button Mouse (PS/2)
             Traceback (innermost last):
               File "/usr/bin/anaconda", line 589, in ?
               File "/usr/lib/anaconda/kickstart.py", line 835, in
                 self.readKickstart(id, self.file)
               File "/usr/lib/anaconda/kickstart.py", line 557, in
                 handlers[args[0]](id, args[1:])
               File "/usr/lib/anaconda/kickstart.py", line 219, in
                 [ 'append=', 'location=', 'useLilo', '--lba32',
               File "/usr/lib/anaconda/isys.py", line 301, in getopt
                 return apply(_isys.getopt, args)
             TypeError: bad argument --lba32: unknown option

             install exited abnormally 

Expected Results:  include the lba32 option in the lilo.conf file

Additional info:

In /usr/lib/anaconda/kickstart.py, the option parsing code is:

                     (args, extra) = isys.getopt(args, '',
                             [ 'append=', 'location=', 'useLilo',
                               'password=', 'md5pass=', 'linear',

             I'm not a python programmer, but It seems very suspicious that
lba32 is the
             option with "--".  I tried using the command:

             bootloader --useLilo --linear ----lba32 --location=mbr

             and that did not crash, but neither did it add the
             lba32 option to the lilo.conf file

There is additional (probably useless) info in Service Request: 195479
Comment 1 Jeremy Katz 2001-11-28 15:58:13 EST
Unfortunately reported in Roswell too late for a fix in 7.2

*** This bug has been marked as a duplicate of 53923 ***

Note You need to log in before you can comment on or make changes to this bug.