Bug 568197 - gstreamer does not handle ogg flac files properly
Summary: gstreamer does not handle ogg flac files properly
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gstreamer
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-02-24 23:47 UTC by cb-rhbugz
Modified: 2010-05-15 20:39 UTC (History)
2 users (show)

Fixed In Version: gstreamer-0.10.29-1.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-15 20:30:55 UTC


Attachments (Terms of Use)
File which gstreamer can't play (50.00 KB, audio/ogg)
2010-02-24 23:47 UTC, cb-rhbugz
no flags Details
file from which gstreamer can't extract metadata (50.00 KB, audio/ogg)
2010-02-24 23:47 UTC, cb-rhbugz
no flags Details

Description cb-rhbugz 2010-02-24 23:47:04 UTC
Created attachment 396187 [details]
File which gstreamer can't play

Description of problem:
Until recently Gstreamer was unable to handle ogg flac files correctly with two problems:
1. does not read metadata
2. some files cannot be parsed with a "bad header error message"

bug #1 is
https://bugzilla.gnome.org/show_bug.cgi?id=608843
https://bugzilla.gnome.org/show_bug.cgi?id=610964 (duplicate with my test case)
bug #2 is
https://bugzilla.gnome.org/show_bug.cgi?id=610959

Version-Release number of selected component (if applicable):
Apparently all versions prior to 0.10.26.2. The bug is present in gstreamer-0.10.26-1.fc12.i686 from F12 updates-testing

How reproducible:
Every time

Steps to Reproduce:
1. try to play test cases with rhythm box
  
Actual results:
aaa.flac.ogg does not play
bbb.flac.ogg is marked unknown artist/title/album

Expected results:
both files play with metadata recognised.

Additional info:
I have not confirmed that the newer version works for me, upstream claim it does, but I can't build it to test.

Comment 1 cb-rhbugz 2010-02-24 23:47:53 UTC
Created attachment 396188 [details]
file from which gstreamer can't extract metadata

Comment 2 Fedora Update System 2010-04-28 19:27:28 UTC
gstreamer-0.10.29-1.fc13,gstreamer-plugins-base-0.10.29-1.fc13,gstreamer-plugins-good-0.10.22-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/gstreamer-0.10.29-1.fc13,gstreamer-plugins-base-0.10.29-1.fc13,gstreamer-plugins-good-0.10.22-1.fc13

Comment 3 Fedora Update System 2010-05-02 12:05:57 UTC
gstreamer-0.10.29-1.fc12,gstreamer-plugins-base-0.10.29-1.fc12,gstreamer-plugins-good-0.10.22-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/gstreamer-0.10.29-1.fc12,gstreamer-plugins-base-0.10.29-1.fc12,gstreamer-plugins-good-0.10.22-1.fc12

Comment 4 Fedora Update System 2010-05-04 06:16:21 UTC
gstreamer-0.10.29-1.fc12, gstreamer-plugins-base-0.10.29-1.fc12, gstreamer-plugins-good-0.10.22-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gstreamer gstreamer-plugins-base gstreamer-plugins-good'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/gstreamer-0.10.29-1.fc12,gstreamer-plugins-base-0.10.29-1.fc12,gstreamer-plugins-good-0.10.22-1.fc12

Comment 5 Fedora Update System 2010-05-06 03:39:09 UTC
gstreamer-0.10.29-1.fc13, gstreamer-plugins-base-0.10.29-1.fc13, gstreamer-plugins-good-0.10.22-2.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gstreamer gstreamer-plugins-base gstreamer-plugins-good'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/gstreamer-0.10.29-1.fc13,gstreamer-plugins-base-0.10.29-1.fc13,gstreamer-plugins-good-0.10.22-2.fc13

Comment 6 Fedora Update System 2010-05-15 20:30:21 UTC
gstreamer-0.10.29-1.fc13, gstreamer-plugins-base-0.10.29-1.fc13, gstreamer-plugins-good-0.10.22-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2010-05-15 20:39:09 UTC
gstreamer-0.10.29-1.fc12, gstreamer-plugins-base-0.10.29-1.fc12, gstreamer-plugins-good-0.10.22-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.