This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 568343 - 13-Alpha.RC3 install from USB drive fails with unknown device
13-Alpha.RC3 install from USB drive fails with unknown device
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
:
: 582887 582895 (view as bug list)
Depends On:
Blocks: F13Blocker/F13FinalBlocker 582380
  Show dependency treegraph
 
Reported: 2010-02-25 08:54 EST by Steve Tyler
Modified: 2010-07-21 09:04 EDT (History)
7 users (show)

See Also:
Fixed In Version: anaconda-13.38-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 582380 616797 (view as bug list)
Environment:
Last Closed: 2010-05-04 18:49:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
anaconda screenshot showing unknown device message (103.85 KB, image/png)
2010-02-25 08:54 EST, Steve Tyler
no flags Details
anaconda screenshot showing "Missing ISO 9660 Image" message (89.93 KB, image/png)
2010-02-25 15:39 EST, Steve Tyler
no flags Details
anaconda 13.36 traceback (236.00 KB, text/plain)
2010-03-25 16:35 EDT, Steve Tyler
no flags Details
screenshot at the point when the traceback was generated (111.83 KB, image/png)
2010-03-25 16:37 EDT, Steve Tyler
no flags Details

  None (edit)
Description Steve Tyler 2010-02-25 08:54:23 EST
Created attachment 396271 [details]
anaconda screenshot showing unknown device  message

Description of problem:
Installing from Fedora-13-Alpha-i386-netinst.iso on a USB drive fails with an error message about an unknown device. Screenshot attached. The UUID is for the USB drive.

NB: My system is 64-bit, but I am booting the 32-bit ISO because the 64-bit ISO fails for another reason.

Version-Release number of selected component (if applicable):
http://serverbeach1.fedoraproject.org/pub/alt/stage/13-Alpha.RC3/Fedora/i386/iso/Fedora-13-Alpha-i386-netinst.iso

[stephent@walnut fedora]$ sha256sum /media/LIVE/Fedora-13-Alpha-i386-netinst.iso 
a2799da3b8d4c8958b09a5a8394216397b9a3d14547803686b36d8fec07b8f1b  /media/LIVE/Fedora-13-Alpha-i386-netinst.iso

How reproducible:
Tried once.

Steps to Reproduce:
1. sudo livecd-iso-to-disk --format Fedora-13-Alpha-i386-netinst.iso /dev/sdc1
2. Boot off USB drive.
3. Follow the onscreen instructions.
  
Actual results:
Install fails.

Expected results:
Install succeeds.

Additional info:
This blkid report was captured while booted off the USB drive.

[stephent@walnut linux_spare]$ cat blkid-anaconda-1.txt 
/dev/loop0: TYPE="squashfs" 
/dev/sda1: LABEL="walnut_boot" UUID="80c8c1fd-cb09-41c9-8404-b8ca010a75bc" TYPE="ext4" 
/dev/sda2: UUID="kT8fYU-UN7Z-If4K-cILr-U2Ak-ebgf-GxBOnv" TYPE="LVM2_member" 
/dev/sda5: LABEL="pecan_root" UUID="05fe594a-bd90-44ba-8dbc-2e6c1de27094" TYPE="ext4" 
/dev/sda6: LABEL="pecan_home" UUID="a377bcbc-0c4d-4f9e-b804-15c14d639ab3" TYPE="ext4" 
/dev/sda7: UUID="39d61b09-9391-4dbd-ab77-e91ebf7cc8d2" TYPE="swap" 
/dev/sdb1: LABEL="cedar_boot" UUID="792d821d-ec1c-44ca-8c90-e98ab92d9650" SEC_TYPE="ext2" TYPE="ext3" 
/dev/sdb2: UUID="820rVv-y7zN-gQUx-E8rV-f2ei-Silh-JEQ5kw" TYPE="LVM2_member" 
/dev/sdb3: LABEL="fir_boot" UUID="910e2c62-5d4e-4601-9b80-0c273941c627" TYPE="ext4" 
/dev/sdb5: LABEL="linux_spare" UUID="62f941ca-5b91-4e90-a1f5-142bdd21fb5e" TYPE="ext4" 
/dev/sdc1: LABEL="LIVE" UUID="9317-C3E2" TYPE="vfat" 
[stephent@walnut linux_spare]$ 

[stephent@walnut linux_spare]$ sudo fdisk -l /dev/sdc

Disk /dev/sdc: 8019 MB, 8019509248 bytes
251 heads, 11 sectors/track, 5672 cylinders
Units = cylinders of 2761 * 512 = 1413632 bytes
Disk identifier: 0x00034ab0

   Device Boot      Start         End      Blocks   Id  System
/dev/sdc1   *           1        5673     7831518+   c  W95 FAT32 (LBA)
Comment 1 Steve Tyler 2010-02-25 09:03:32 EST
(In reply to comment #0)
> NB: My system is 64-bit, but I am booting the 32-bit ISO because the 64-bit ISO
> fails for another reason.

Same thing happens on my 32-bit laptop.
Comment 2 Chris Lumens 2010-02-25 09:50:40 EST
Is your install source listed in the filtering UI there?  If so, could you please check it and see if you get past this screen?
Comment 3 Steve Tyler 2010-02-25 10:16:34 EST
Clicking "Exit installer" gives a black display with a responsive pointer. The consoles work, and it is possible to reboot from a console. (Verified on two systems.)

Checking "Lexar USB Flash Drive" in addition to the intended destination drive allows the installation to proceed to the next step.

Comment: The function of this dialog is not at all clear (in screenshot). Is it the "filtering UI"?
Comment 4 Steve Tyler 2010-02-25 10:57:53 EST
(In reply to comment #2)
> Is your install source listed in the filtering UI there?

Yes, my install source is the "Lexar USB Flash Drive".
Comment 5 Steve Tyler 2010-02-25 15:39:06 EST
Created attachment 396386 [details]
anaconda screenshot showing "Missing ISO 9660 Image" message

By checking "Lexar USB Flash Drive" I was able to get to this point:

"Missing ISO 9660 Image"

I chose basic install and custom disk layout (to install everything on one partition).
Comment 6 Steve Tyler 2010-03-25 16:35:54 EDT
Created attachment 402670 [details]
anaconda 13.36 traceback

Reproduced with:

anaconda 13.36
F13-Beta-TC1
Fedora-13-Beta-x86_64-netinst.iso
http://serverbeach1.fedoraproject.org/pub/alt/stage/13-Beta.TC1/Fedora/x86_64/iso/

USB stick was installed with:
$ sudo livecd-iso-to-disk --format Fedora-13-Beta-x86_64-netinst.iso /dev/sdc1

Traceback was generated with USR2 magic trick ... :-)
Comment 7 Steve Tyler 2010-03-25 16:37:14 EDT
Created attachment 402671 [details]
screenshot at the point when the traceback was generated
Comment 8 Steve Tyler 2010-03-25 16:55:08 EDT
After rebooting into F12:

[stephent@walnut ~]$ sudo blkid -s none
[stephent@walnut ~]$ sudo blkid | grep sdc
/dev/sdc1: LABEL="LIVE" UUID="3B82-3458" TYPE="vfat" 

[stephent@walnut ~]$ sudo dosfslabel /dev/sdc1
There are differences between boot sector and its backup.
Differences: (offset:original/backup)
  90:fa/0e, 91:fc/1f, 92:31/be, 93:c0/77, 94:8e/7c, 95:d0/ac, 96:bc/22
  , 97:b4/c0, 98:7b/74, 99:06/0b, 100:57/56, 101:8e/b4, 102:c0/0e, 103:b9/bb
  , 104:08/07, 106:bf/cd, 107:b4/10, 108:7b/5e, 109:f3/eb, 110:a5/f0
...
  , 495:6f/00, 496:72/00, 497:0d/00, 498:0a/00, 504:ae/00, 505:98/00
  , 506:0b/00, 508:7f/00
  Not automatically fixing this.
LIVE       
[stephent@walnut ~]$ 

[stephent@walnut ~]$ sudo fdisk -l /dev/sdc

Disk /dev/sdc: 8019 MB, 8019509248 bytes
251 heads, 11 sectors/track, 5672 cylinders
Units = cylinders of 2761 * 512 = 1413632 bytes
Disk identifier: 0x4606c5c9

   Device Boot      Start         End      Blocks   Id  System
/dev/sdc1   *           1        5673     7831518+   c  W95 FAT32 (LBA)
[stephent@walnut ~]$
Comment 9 Chris Lumens 2010-03-25 17:11:13 EDT
Please don't repurpose this bug to talk about other issues as well.  I'm actively working on a patch for the original issue and should have something by tomorrow.  Adding various other problems is just going to confuse matters.
Comment 10 Steve Tyler 2010-03-25 17:20:35 EDT
(In reply to comment #9)
> Please don't repurpose this bug to talk about other issues as well.  I'm
> actively working on a patch for the original issue and should have something by
> tomorrow.  Adding various other problems is just going to confuse matters.    

Sheesh, what did I do wrong now? I was reproducing this exact bug with F13-Beta-TC1 ...
Comment 11 Chris Lumens 2010-03-26 14:13:31 EDT
Pushed a fix to master, waiting to find out whether everyone else agrees that this is really a blocker before pushing to f13-branch.  I love process.
Comment 12 Steve Tyler 2010-03-26 14:34:43 EDT
(In reply to comment #11)
> Pushed a fix to master, waiting to find out whether everyone else agrees that
> this is really a blocker before pushing to f13-branch.  I love process.    

<g> Thanks, Chris. Looking back, I see there were two problems. There is an easy work-around for the first one (comment 2, comment 3), namely checking the USB stick. The second problem ("Missing ISO 9660 Image", comment 5) would seem to be a blocker for USB stick installation. Can you suggest a work-around to try?
Comment 13 James Laska 2010-03-29 13:16:09 EDT
(In reply to comment #11)
> Pushed a fix to master, waiting to find out whether everyone else agrees that
> this is really a blocker before pushing to f13-branch.  I love process.    

I don't have objections to taking this fix for F13 Final.  But I should note that it seems using livecd-iso-to-disk in this manner is not a supported use of livecd-tools according to livecd-tools maintainer.

The fixes in question are listed below for reference:
 * http://git.fedorahosted.org/git/?p=anaconda.git;a=commit;h=8e62952a0e52d9ac5df781eb2f4ff5915208602b
 * http://git.fedorahosted.org/git/?p=anaconda.git;a=commit;h=969bc59946f528b273d1309e4e8f489d5821cdcb
Comment 14 Steve Tyler 2010-03-29 14:53:20 EDT
(In reply to comment #13)
...
> But I should note
> that it seems using livecd-iso-to-disk in this manner is not a supported use of
> livecd-tools according to livecd-tools maintainer.
...

The F12 installation guide documents the use of livecd-iso-to-disk here.
AIUI, boot.iso and *netinst.iso are identical.

http://docs.fedoraproject.org/install-guide/f12/en-US/html-single/#sect-New_Users-Alternative_Boot_Methods
Comment 15 James Laska 2010-03-29 16:10:06 EDT
(In reply to comment #14)
> (In reply to comment #13)
> ...
> > But I should note
> > that it seems using livecd-iso-to-disk in this manner is not a supported use of
> > livecd-tools according to livecd-tools maintainer.
> ...
> 
> The F12 installation guide documents the use of livecd-iso-to-disk here.
> AIUI, boot.iso and *netinst.iso are identical.
> 
> http://docs.fedoraproject.org/install-guide/f12/en-US/html-single/#sect-New_Users-Alternative_Boot_Methods    

Thanks for the link Steve.  The linked document only pertains to boot.iso (netinst.iso).  The livecd-tools maintainer, indicated that livecd-iso-to-disk is not supported for writing DVD media to a USB key for install.  We'll need to chase that down outside of this specific bug.
Comment 16 Chris Lumens 2010-04-16 10:23:01 EDT
*** Bug 582887 has been marked as a duplicate of this bug. ***
Comment 17 Chris Lumens 2010-04-16 10:27:20 EDT
*** Bug 582895 has been marked as a duplicate of this bug. ***
Comment 18 Jens Petersen 2010-04-22 04:04:03 EDT
Moving back to assigned until a fix is in the testing repo.
Comment 19 Jens Petersen 2010-04-22 04:08:58 EDT
BTW I think a workaround is to go into the boot.iso boot menu and
remove the last kernel option (hd_repo=....), but not very obvious.
Comment 20 Marcus Moeller 2010-04-29 09:28:50 EDT
Original issue also affects RHEL 6. Sorry, not willed to open another bug for that. Maybe Bugzilla will somewhen have an option to declare affected target distributions.
Comment 21 Adam Williamson 2010-05-03 20:57:23 EDT
Testing with TC1:

after writing netinst.iso to a USB stick with livecd-iso-to-disk (from an up-to-date F13 machine), I can successfully boot the stick and proceed deep into installation. I note that, at the stage where you select what storage devices will be involved in the install, the USB stick is pre-selected and it is impossible to de-select it. However, at the 'Data Storage Devices' / 'Install Target Devices' stage I run into another bug, which I've described at https://bugzilla.redhat.com/show_bug.cgi?id=588493#c2 . Not sure if that should now be nominated a blocker. I think this specific bug is fixed, though. Should we close?



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 22 Adam Williamson 2010-05-04 18:49:02 EDT
we're tracking the other problem in that other bug, so closing this.

Note You need to log in before you can comment on or make changes to this bug.