Bug 56844 - Non-root usage not working.
Non-root usage not working.
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: xcdroast (Show other bugs)
7.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Aaron Brown
:
: 58429 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-28 13:29 EST by John Verel
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-03 06:32:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Verel 2001-11-28 13:29:22 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.72 [en] (Win95; U)

Description of problem:
xcdroast version 0.98alpha9, as distributed by Red Hat, has the non root 
usage configuration disabled.  This is confirmed by notes from the package 
author on www.xcdroast.com.

Version-Release number of selected component (if applicable):
0.98alpha9


How reproducible:
Always

Steps to Reproduce:
1.Install xcdroast from RH7.2 distro.
2.Configure for non-root usage, per xcdroast README.nonroot
3.Attempt to use application from user account.
	

Actual Results:  User is prompted for root password.  If not provided, 
program will not start.

Expected Results:  Normal startup, without root password prompt.

Additional info:

This is a bug because the package should be able to be configured as is 
described in the documentation distributed with RH 7.2.  It does not 
perform as documented.

A workaround is to download newly released rpm from www.xcdroast.com and 
install. Problem is eliminated.  I see no reason why non root usage should 
not be an option in the Red Hat released version.

New rpm from above site puts xcdroast menu entry in Applications, rather 
than Multimedia under Gnome, as had been the case with the Red Hat Distro.

Installation script for new rpm also seems to set up permissions for non 
root usage automatically.
Comment 1 Tim Waugh 2001-11-28 13:40:30 EST
Thanks for pointing this out.  I just had a look at the spec file, and there 
are a couple of things that need changing before it can be used.  I'll talk to 
the upstream maintainer about them.
Comment 2 Tim Waugh 2001-11-29 09:09:12 EST
Okay.

The permissions being set up in the %post section is a no-no: it means that 
'rpm -V ...' will always fail, and that's bad news.  And changing the 
permissions of files that the package doesn't even own is really nasty.

The way it is supposed to work is that console users have the access that they 
need, rather than having a separate group for that.  Otherwise it means 
changes in the cdrecord package, and other packages, etc.  Plus, I think that 
this suits the vast majority of users, who don't know or care what groups are.

However, I think that the console.apps file that makes this happen is wrong: 
it asks for root's password rather than the user's.  That's easy to fix.

As for the issue concerning the desktop file: this was changed for bug #50290.
Comment 3 Tim Waugh 2001-11-30 08:56:13 EST
A fixed package has been built as xcdroast-0.98a9-3.
Comment 4 John Verel 2001-12-01 16:52:06 EST
New package, xcdroast-0.98a9-3, picked up from rawhide ftp site does not
install:  says libpng.so.3 is needed by xcdroast-0.98a9-3, which is provided by
libpng-1.2.0-1.i386, again from rawhide.  Attempted to upgrade libpng to latter
version.  Got multiple messages saying libpng.so.2 is needed by many different
packages, this object in turn being provided by libpng-1.0.12-2, standard with
RH7.2.  Couldn't this xcdroast version be built against the current libpng
distributed with RH7.2?
Comment 5 Tim Waugh 2001-12-02 05:35:49 EST
You need to install both libpng10 and libpng to install rawhide packages that 
use libpng.  libpng10 is the compatibility library, and libpng is the newer 
(but ABI incompatible) version.
Comment 6 John Verel 2001-12-02 18:44:25 EST
Did as advised above, re libpng10 and libpng -- and libpng-devel, for good
measure .  Started fine in root, but only from root login session. Would not
start from su-ing to root in gnome terminal (non-login bash shell) from user
session and executing xcdroast, complaining:
Xlib: connection to ":0.0" refused by server
Xlib: Client is not authorized to connect to Server.  

Same behavior if done from login bash shell.

First start in user account, from console, got prompted for USER password
(good!) but got error messages saying permissions on xcdrwrapper were wrong,
with following message (although did start okay):

** WARNING **: The X-CD-Roast wrapper seems not to have the correct
	 permissions set

** WARNING **: So do as root something like that: 
	 chown root:cdwrite /usr/lib/xcdroast-0.98/bin/xcdrwrap;
	 chmod 2755 /usr/lib/xcdroast-0.98/bin/xcdrwrap


** WARNING **: For more information read 
	/usr/share/doc/xcdroast-0.98a9/README.nonroot

*** NOTE ***:
	---------------------------------------------------------------
	This permission warning and the following set-uid bit warnings
	can be safely ignored, if you want to run X-CD-Roast as root only.
	---------------------------------------------------------------
Note:  README.nonroot unchanged from prior version, still indicating change of
ownership and permissions.

Did chown root:cdwrite and chmod 2755 to xcdrwrapper.  Started without
permission/ownership warnings.  However, I get the following messages:
libpng warning: Application was compiled with png.h from libpng-1.0.12
libpng warning: Application  is running with png.c from libpng-1.2.0
libpng error: Incompatible libpng version in application and library

Have not yet attempted burn but seems to install and configure okay.
Comment 7 Tim Waugh 2001-12-03 06:32:15 EST
Most of the errors are expected: xcdroast itself is running as root, and this 
is unfortunate.  It's a side-effect of the console-user pam stuff. :-(

The libpng warnings are to do with gtk---it needs to be recompiled against the 
libpng in rawhide, but it currently doesn't compile with the autoconf we have 
there.  It'll be fixed before release, but the easiest work-around would 
probably be to downgrade to the xcdroast that came with Red Hat Linux 7.2 and 
replace the contents of /etc/security/console.apps/xcdroast with:

USER=<user>
PROGRAM=/usr/sbin/xcdroast
SESSION=false

I'll add a note to this report when the libpng problem has been resolved.
Comment 8 Tim Waugh 2001-12-18 12:28:35 EST
I don't know if the problems are resolved, but I'm going to mark this as 
RESOLVED RAWHIDE, since the original problem is fixed.  There are compiler 
things going on in rawhide at the moment so the package probably won't be much 
use to you (unless you are tracking _all_ of rawhide), but the work-around is 
detailed above.
Comment 9 Tim Waugh 2002-01-16 09:13:49 EST
*** Bug 58429 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.