Bug 58429 - nonroot-mode needs root
nonroot-mode needs root
Status: CLOSED DUPLICATE of bug 56844
Product: Red Hat Linux
Classification: Retired
Component: xcdroast (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Aaron Brown
Depends On:
  Show dependency treegraph
Reported: 2002-01-16 09:09 EST by Andrew Gormanly
Modified: 2007-04-18 12:39 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-01-16 09:09:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Andrew Gormanly 2002-01-16 09:09:06 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.9-12 i686)

Description of problem:
I want to be able to give ordinary users on our LAN the ability to burn CDs with
their CD writers but can't go giving them the root passwords.

xcdroast claims to support non-root operation and there are instructions for
setting this up, but after following these I run as an ordinary user and am
asked for the root password.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Follow the instructions in /usr/share/doc/xcdroast-0.98a9/README.nonroot
2. Run xcdroast as an ordinary user

Actual Results:  I am asked for the root pasword.

Expected Results:  The user account should be able to burn a CD

Additional info:

From the xcdroast changelog:

* Mon Jul 23 2001 Karsten Hopp <karsten@redhat.de> 0.98a9-1

- 0.98a9
- give hint how to setup nonroot-mode (we don't ship the sgid binaries)

Despite following the instructions in
/usr/share/doc/xcdroast-0.98a9/README.nonroot I get a pop-up window:

In order to run "xcdroast" with root's privileges, additional information is
Password for root:

Choices are OK or Cancel.
Comment 1 Tim Waugh 2002-01-16 09:13:54 EST

*** This bug has been marked as a duplicate of 56844 ***

Note You need to log in before you can comment on or make changes to this bug.