Bug 56890 - M-x gdb arrow invisible in emacs-21.1-0.4
M-x gdb arrow invisible in emacs-21.1-0.4
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: emacs (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
Aaron Brown
:
: 72609 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-29 12:23 EST by Jonathan Kamens
Modified: 2007-04-18 12:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-27 11:59:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to python-mode.el (826 bytes, patch)
2002-06-11 12:46 EDT, Jason Merrill
no flags Details | Diff

  None (edit)
Description Jonathan Kamens 2001-11-29 12:23:55 EST
Date: Thu, 29 Nov 2001 09:40:54 -0500
From: Jonathan Kamens <jik@kamens.brookline.ma.us>
To: bug-gnu-emacs@gnu.org
Subject: emacs in xterm -- arrow invisible in M-x gdb

This bug report will be sent to the Free Software Foundation,
not to your local site managers!
Please write in English, because the Emacs maintainers do not have
translators to read other languages for them.

Your bug report will be posted to the bug-gnu-emacs@gnu.org mailing list,
and to the gnu.emacs.bug news group.

In GNU Emacs 21.1.1 (i386-redhat-linux-gnu, X toolkit, Xaw3d scroll bars)
 of 2001-11-06 on stripples.devel.redhat.com
configured using `configure  i386-redhat-linux --prefix=/usr
--exec-prefix=/usr --bindir=/usr/bin --sbindir=/usr/sbin --sysconfdir=/etc
--datadir=/usr/share --includedir=/usr/include --libdir=/usr/lib
--libexecdir=/usr/libexec --localstatedir=/var --sharedstatedir=/usr/com
--mandir=/usr/share/man --infodir=/usr/share/info --with-gcc --with-pop
--with-sound'
Important settings:
  value of $LC_ALL: nil
  value of $LC_COLLATE: C
  value of $LC_CTYPE: nil
  value of $LC_MESSAGES: nil
  value of $LC_MONETARY: nil
  value of $LC_NUMERIC: nil
  value of $LC_TIME: nil
  value of $LANG: en_US
  locale-coding-system: iso-latin-1
  default-enable-multibyte-characters: t

Please describe exactly what actions triggered the bug
and the precise symptoms of the bug:

I'm using "emacs -nw -q" in an xterm.  When I use M-x gdb to debug a
program, put in a breakpoint and run the program, the arrow showing me
where I am is not visible when the breakpoint is hit.  If I type
"frame 0", the arrow flashes and then disappears again.

Note that I've got my xterm configured with a foreground color of
green and a background color of black, but I'm not sure how relevant
this is (since if this were a color problem, I imagine that the arrow
wouldn't flash even briefly).  Note, furthermore, that I see this
problem with two different versions of xterm -- the one in Red Hat's
XFree86 3.3.6 package, and the one in Red Hat's XFree86 4.1.0 package.

  jik

                      *************************

Date: Thu, 29 Nov 2001 19:15:11 +0200 (IST)
From: Eli Zaretskii <eliz@is.elta.co.il>
To: Jonathan Kamens <jik@kamens.brookline.ma.us>
cc: bug-gnu-emacs@gnu.org
Subject: Re: emacs in xterm -- arrow invisible in M-x gdb


On Thu, 29 Nov 2001, Jonathan Kamens wrote:

> I'm using "emacs -nw -q" in an xterm.  When I use M-x gdb to debug a
> program, put in a breakpoint and run the program, the arrow showing me
> where I am is not visible when the breakpoint is hit.

Is the arrow visible when you step through the program with `n'?  More 
generally, could you describe the circumstances which make the arrow 
disappear (unless it is never visible)?  I did some simple tests, and it 
seems that for me, the arrow is always visible.  So perhaps you do 
something special do trigger this problem.

                      *************************

Date: Thu, 29 Nov 2001 12:21:48 -0500
From: Jonathan Kamens <jik@kamens.brookline.ma.us>
To: bug-gnu-emacs@gnu.org
Subject: Re: emacs in xterm -- arrow invisible in M-x gdb

>  Date: Thu, 29 Nov 2001 19:15:11 +0200 (IST)
>  From: Eli Zaretskii <eliz@is.elta.co.il>
>  
>  Is the arrow visible when you step through the program with `n'?

No.

>  More generally, could you describe the circumstances which make the
>  arrow disappear (unless it is never visible)?

It is never visible (except for the flashes I noted previously).

I will report the problem to Red Hat as well, since I am using a Red
Hat Emacs package.  Perhaps they've customized Emacs in some way that
is causing this problem.

  jik
Comment 1 Trond Eivind Glomsrxd 2001-11-29 15:45:05 EST
"(require 'python-mode)" is the culprit - something's not quite right in there.
Comment 2 Trond Eivind Glomsrxd 2001-11-29 16:41:13 EST
It's also different between emacs 20 and emacs 21 - (require 'python-mode) break
the arrow in emacs 21, while it works in emacs 20. Please forward that
information to your emacs bug report.
Comment 3 Jonathan Kamens 2001-11-29 16:46:21 EST
I think perhaps you should correspond with bug-gnu-emacs directly.  It doesn't
seem like there's any advantage to my acting as a middle man at this point.
Comment 4 Jonathan Kamens 2002-02-10 17:28:58 EST
You're not going to ship without fixing this, are you?
Comment 5 Jason Merrill 2002-06-11 12:46:31 EDT
Created attachment 60545 [details]
patch to python-mode.el
Comment 6 Jason Merrill 2002-06-11 12:48:55 EDT
I've attached my patch for this bug, which is still present in 7.3.  The
SourceForge python project page has another pending patch for this bug, too; I
didn't notice it until I went to submit mine.  And I like mine better, anyway.
Comment 7 Trond Eivind Glomsrxd 2002-08-26 18:15:49 EDT
*** Bug 72609 has been marked as a duplicate of this bug. ***
Comment 8 Alexandre Oliva 2002-08-26 22:53:55 EDT
Is there any reason why Jason's patch has not been integrated yet?
Comment 9 Trond Eivind Glomsrxd 2002-08-27 11:59:27 EDT
emacs-21.2-17 should fix this.

Note You need to log in before you can comment on or make changes to this bug.