This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 72609 - gdb mode won't display current line marker
gdb mode won't display current line marker
Status: CLOSED DUPLICATE of bug 56890
Product: Red Hat Public Beta
Classification: Retired
Component: emacs (Show other bugs)
null
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-26 00:19 EDT by Alexandre Oliva
Modified: 2015-01-07 18:59 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-26 00:19:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2002-08-26 00:19:28 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020809

Description of problem:
The GDB (gud) mode in earlier releases of GNU Emacs (say 20.7) would display a
`=>' overlay in the beginning of the line being executed in a C program.  The
current version does not.

At first, I thought it was being smart and taking advantage of the fact that, on
X, it might as well just position the cursor on the active line, and let the
cursor work as the marker.

However, even emacs -nw fails to display the `=>' marker.  Or, more accurately,
it *does* display it, but it's quickly overwritten by something else.  This
makes it almost impossible to run a remote debugging session, since X isn't
really usable over low latencies.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Create a program, say foo.c:
  main () {
  }
2.Compile it with debugging info:
  % gcc -g -o foo foo.c
3.Start emacs in text mode:
  % emacs -nw
4.Start the debugger:
  M-x gdb ENTER foo ENTER
5.Set a breakpoint and start the program
  (gdb) b main
  (gdb) run
6.Try to figure out which is the active line.


Actual Results:  You can't figure it out unless you look at the line number in
the context bar, and translate that info into one of the lines being displayed
(can be tricky in a large file)

Expected Results:  The `=>' overlay should not be overwritten.

Additional info:
Comment 1 Trond Eivind Glomsrxd 2002-08-26 18:15:55 EDT

*** This bug has been marked as a duplicate of 56890 ***

Note You need to log in before you can comment on or make changes to this bug.